summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-03 19:25:36 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-03 19:25:36 +0000
commit13da29fe2ea95da2dabaa3364529d2ad0f74a489 (patch)
tree635f08fbce2b45ae21ad42d289736c92aab2ad1b /dev-util
parentmask for new versions of gnustep programs (diff)
downloadgentoo-2-13da29fe2ea95da2dabaa3364529d2ad0f74a489.tar.gz
gentoo-2-13da29fe2ea95da2dabaa3364529d2ad0f74a489.tar.bz2
gentoo-2-13da29fe2ea95da2dabaa3364529d2ad0f74a489.zip
Version bump on gnustep. Currently masked. This bumps all the unstable
builds to stable revisions. gcc3 is required for these packages.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gnustep-back/ChangeLog11
-rw-r--r--dev-util/gnustep-back/files/digest-gnustep-back-0.8.01
-rw-r--r--dev-util/gnustep-back/gnustep-back-0.8.0.ebuild42
-rw-r--r--dev-util/gnustep-base/ChangeLog24
-rw-r--r--dev-util/gnustep-base/files/digest-gnustep-base-1.4.01
-rw-r--r--dev-util/gnustep-base/gnustep-base-1.4.0.ebuild36
-rw-r--r--dev-util/gnustep-gui/ChangeLog11
-rw-r--r--dev-util/gnustep-gui/files/digest-gnustep-gui-0.8.01
-rw-r--r--dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild39
-rw-r--r--dev-util/gnustep-make/ChangeLog18
-rw-r--r--dev-util/gnustep-make/files/digest-gnustep-make-1.4.01
-rw-r--r--dev-util/gnustep-make/gnustep-make-1.4.0.ebuild37
12 files changed, 194 insertions, 28 deletions
diff --git a/dev-util/gnustep-back/ChangeLog b/dev-util/gnustep-back/ChangeLog
index a2f736b6542b..ac09f1e7d570 100644
--- a/dev-util/gnustep-back/ChangeLog
+++ b/dev-util/gnustep-back/ChangeLog
@@ -1,10 +1,15 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for dev-util/gnustep-back
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/ChangeLog,v 1.1 2002/07/19 20:40:13 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/ChangeLog,v 1.2 2002/09/03 19:25:35 raker Exp $
+
+*gnustep-back-0.8.0 (03 Sep 2002)
+
+ 03 Sep 2002; Nick Hadaway <raker@gentoo.org> gnustep-back-0.8.0.ebuild,
+ files/digest-gnustep-back-0.8.0 :
+ Version bump.
*gnustep-back-0.7.9 (19 Jul 2002)
19 Jul 2002; Nick Hadaway <raker@gentoo.org>
gnustep-back-0.7.9.ebuild, ChangeLog, files/digest-gnustep-back-0.7.9 :
-
Initial ebuild.
diff --git a/dev-util/gnustep-back/files/digest-gnustep-back-0.8.0 b/dev-util/gnustep-back/files/digest-gnustep-back-0.8.0
new file mode 100644
index 000000000000..0b99743ed2a8
--- /dev/null
+++ b/dev-util/gnustep-back/files/digest-gnustep-back-0.8.0
@@ -0,0 +1 @@
+MD5 dfa9caa98acce96f394afeacc77665b1 gnustep-back-0.8.0.tar.gz 263324
diff --git a/dev-util/gnustep-back/gnustep-back-0.8.0.ebuild b/dev-util/gnustep-back/gnustep-back-0.8.0.ebuild
new file mode 100644
index 000000000000..eee476b1100c
--- /dev/null
+++ b/dev-util/gnustep-back/gnustep-back-0.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/gnustep-back-0.8.0.ebuild,v 1.1 2002/09/03 19:25:35 raker Exp $
+
+DESCRIPTION="GNUstep GUI backend"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND=">=dev-util/gnustep-gui-0.8.0
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2
+ x11-base/xfree"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ ./configure --prefix=/usr/GNUstep \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
+ --with-x \
+ || die "configure failed"
+
+ make || die
+
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ make \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ install || die "install failed"
+
+}
diff --git a/dev-util/gnustep-base/ChangeLog b/dev-util/gnustep-base/ChangeLog
index ad2fbf164e1d..8a47cdcad500 100644
--- a/dev-util/gnustep-base/ChangeLog
+++ b/dev-util/gnustep-base/ChangeLog
@@ -1,39 +1,37 @@
# ChangeLog for dev-util/gnustep-base
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# Author Nick Hadaway <raker@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/ChangeLog,v 1.5 2002/07/19 17:27:49 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/ChangeLog,v 1.6 2002/09/03 19:25:35 raker Exp $
+
+*gnustep-base-1.4.0 (03 Sep 2002)
+
+ 03 Sep 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.4.0.ebuild,
+ files/digest-gnustep-base-1.4.0 :
+ Version bump.
*gnustep-base-1.3.4-r1 (19 Jul 2002)
19 Jul 2002; Nick Hadaway <raker@gentoo.org>
gnustep-base-1.3.4-r1.ebuild, files/digest-gnustep-base-1.3.4-r1 :
-
Figured out install variables. No longer doing manual file install.
Fixed some typos in the ChangeLog.
-*gnustep-base-1.1.0 (07 Jul 2002)
-
- 07 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.1.0.ebuild:
-
- Back to the stable version. Cleaned up the ebuild and should now install
- properly.
-
*gnustep-base-1.3.4 (05 Jul 2002)
05 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.3.4.ebuild:
-
Updated to the 1.3.4 package. libxml2 now appears to be detected.
Currently fails compiling, so masked in package.mask
*gnustep-base-1.3.3 (04 Jul 2002)
04 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.3.3.ebuild:
-
Updated to the 1.3.3 package. libxml2 is currently not detected correctly.
*gnustep-base-1.1.0 (04 Jul 2002)
+ 07 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.1.0.ebuild:
+ Back to the stable version. Cleaned up the ebuild and should now install
+ properly.
+
04 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.1.0.ebuild:
-
This is the first ebuild for this package. The GNUstep base package.
diff --git a/dev-util/gnustep-base/files/digest-gnustep-base-1.4.0 b/dev-util/gnustep-base/files/digest-gnustep-base-1.4.0
new file mode 100644
index 000000000000..07781b850415
--- /dev/null
+++ b/dev-util/gnustep-base/files/digest-gnustep-base-1.4.0
@@ -0,0 +1 @@
+MD5 2eff09a24fe02e36dc7cdf8e4f60823e gnustep-base-1.4.0.tar.gz 1572242
diff --git a/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild b/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild
new file mode 100644
index 000000000000..334e382aaa40
--- /dev/null
+++ b/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild,v 1.1 2002/09/03 19:25:35 raker Exp $
+
+DESCRIPTION="GNUstep base package"
+HOMEPAGE="http://www.gnustep.org"
+LICENSE="LGPL"
+DEPEND=">=dev-util/gnustep-make-1.4.0
+ >=dev-libs/libxml2-2.4.23"
+RDEPEND="virtual/glibc"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="x86 -ppc sparc sparc64"
+SLOT="0"
+
+src_compile() {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+ econf \
+ --with-xml-prefix=/usr \
+ --with-gmp-include=/usr/include \
+ --with-gmp-library=/usr/lib || die "./configure failed"
+
+ make || die
+
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ make install \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ || die "install failed"
+
+}
diff --git a/dev-util/gnustep-gui/ChangeLog b/dev-util/gnustep-gui/ChangeLog
index 6657ffbe32ea..35d0f519e427 100644
--- a/dev-util/gnustep-gui/ChangeLog
+++ b/dev-util/gnustep-gui/ChangeLog
@@ -1,10 +1,15 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for dev-util/gnustep-gui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-gui/ChangeLog,v 1.1 2002/07/19 20:24:42 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-gui/ChangeLog,v 1.2 2002/09/03 19:25:36 raker Exp $
+
+*gnustep-gui-0.8.0 (03 Aug 2002)
+
+ 03 Aug 2002; Nick Hadaway <raker@gentoo.org> gnustep-gui-0.8.0.ebuild,
+ files/digest-gnustep-gui-0.8.0 :
+ Version bump.
*gnustep-gui-0.7.9 (19 Jul 2002)
19 Jul 2002; Nick Hadaway <raker@gentoo.org>
gnustep-gui-0.7.9.ebuild, ChangeLog, files/digest-gnustep-gui-0.7.9 :
-
Initial ebuild.
diff --git a/dev-util/gnustep-gui/files/digest-gnustep-gui-0.8.0 b/dev-util/gnustep-gui/files/digest-gnustep-gui-0.8.0
new file mode 100644
index 000000000000..ca94121f6515
--- /dev/null
+++ b/dev-util/gnustep-gui/files/digest-gnustep-gui-0.8.0
@@ -0,0 +1 @@
+MD5 b031634efa8c75a38e45eff7056f3b2a gnustep-gui-0.8.0.tar.gz 1892916
diff --git a/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild b/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild
new file mode 100644
index 000000000000..2b3f3177235a
--- /dev/null
+++ b/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild,v 1.1 2002/09/03 19:25:36 raker Exp $
+
+DESCRIPTION="GNUstep AppKit implementation"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND=">=dev-util/gnustep-base-1.4.0
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ ./configure --prefix=/usr/GNUstep \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
+ || die "configure failed"
+
+ make LD_LIBRARY_PATH=$LD_LIBRARY_PATH || die
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ make \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ install || die "install failed"
+
+}
diff --git a/dev-util/gnustep-make/ChangeLog b/dev-util/gnustep-make/ChangeLog
index ca471de84aac..8cca81e270b2 100644
--- a/dev-util/gnustep-make/ChangeLog
+++ b/dev-util/gnustep-make/ChangeLog
@@ -1,35 +1,35 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for dev-util/gnustep-make
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# Author Nick Hadaway <raker@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-make/ChangeLog,v 1.4 2002/07/19 16:07:39 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-make/ChangeLog,v 1.5 2002/09/03 19:25:36 raker Exp $
-*gnustep-make-1.3.4-r1 (19 Jul 2002)
+*gnustep-make-1.4.0 (03 Sep 2002)
+
+ 03 Sep 2002; Nick Hadaway <raker@gentoo.org> gnustep-make-1.4.0.ebuild,
+ files/digest-gnustep-make-1.4.0 :
+ Version bump.
- 19 Jul 2002; Nick hadaway <raker@gentoo.org>gentoo-make-1.3.4-r1.ebuild :
+*gnustep-make-1.3.4-r1 (19 Jul 2002)
+ 19 Jul 2002; Nick hadaway <raker@gentoo.org> gentoo-make-1.3.4-r1.ebuild :
Scrapped the manual file install. Finally figured out the required
variables to pass to make install.
*gnustep-make-1.3.4 (05 Jul 2002)
19 Jul 2002; Nick Hadaway <raker@gentoo.org> gentoo-make-1.3.4.ebuild:
-
Changed mkdir -p to dodir. SLOT and KEYWORDS added.
05 Jul 2002; Nick Hadaway <raker@getntoo.org> gentoo-make-1.3.4.ebuild:
-
It seems as soon as you get a package done, a new version is out.
added "makefile.make". Currently masked to keep in line with gnustep-base.
*gnustep-make-1.3.3 (04 Jul 2002)
04 Jul 2002; Nick Hadaway <raker@getntoo.org> gentoo-make-1.3.3.ebuild:
-
Updated to the "unstable" tree.
*gnustep-make-1.2.1 (03 Jul 2002)
03 Jul 2002; Nick Hadaway <raker@gentoo.org> gentoo-make-1.2.1.ebuild:
-
This is the first ebuild for this package. The first core gnustep
package.
diff --git a/dev-util/gnustep-make/files/digest-gnustep-make-1.4.0 b/dev-util/gnustep-make/files/digest-gnustep-make-1.4.0
new file mode 100644
index 000000000000..d2b34169c348
--- /dev/null
+++ b/dev-util/gnustep-make/files/digest-gnustep-make-1.4.0
@@ -0,0 +1 @@
+MD5 dbd34cc71a2445dca580f0f2b0a759ab gnustep-make-1.4.0.tar.gz 312564
diff --git a/dev-util/gnustep-make/gnustep-make-1.4.0.ebuild b/dev-util/gnustep-make/gnustep-make-1.4.0.ebuild
new file mode 100644
index 000000000000..0e3b45a482ed
--- /dev/null
+++ b/dev-util/gnustep-make/gnustep-make-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-make/gnustep-make-1.4.0.ebuild,v 1.1 2002/09/03 19:25:36 raker Exp $
+
+DESCRIPTION="GNUstep makefile package (unstable)"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-3.1
+ >=dev-libs/ffcall-1.8d
+ >=dev-libs/gmp-3.1.1
+ >=dev-util/guile-1.4
+ >=dev-libs/openssl-0.9.6d
+ >=media-libs/tiff-3.5.7-r1
+ >=dev-libs/libxml2-2.4.22
+ >=x11-wm/WindowMaker-0.80.1"
+
+LICENSE="LGPL"
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+
+ make \
+ GNUSTEP_SYSTEM_ROOT=${D}/usr/GNUstep/System \
+ GNUSTEP_LOCAL_ROOT=${D}/usr/GNUstep/Local \
+ GNUSTEP_NETWORK_ROOT=${D}/usr/GNUstep/Network \
+ install || die "install failed"
+
+}