summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2005-05-27 17:34:59 +0000
committerStefan Jones <cretin@gentoo.org>2005-05-27 17:34:59 +0000
commitb12e18f6367e9c06b1290efa25097e1d1f5a1954 (patch)
treed477bffdefa8788f9f068df6c271a666d6fa4e8e /dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild
parentNew versio and cleanup (diff)
downloadgentoo-2-b12e18f6367e9c06b1290efa25097e1d1f5a1954.tar.gz
gentoo-2-b12e18f6367e9c06b1290efa25097e1d1f5a1954.tar.bz2
gentoo-2-b12e18f6367e9c06b1290efa25097e1d1f5a1954.zip
New version and cleanup
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild')
-rw-r--r--dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild b/dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild
new file mode 100644
index 000000000000..b86967cdb20d
--- /dev/null
+++ b/dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-runtime/xmingw-runtime-3.7.ebuild,v 1.1 2005/05/27 17:34:59 cretin Exp $
+
+inherit eutils
+
+MY_P=${P/xming/ming}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org"
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-util/xmingw-binutils
+ dev-util/xmingw-gcc
+ dev-util/xmingw-w32api"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.5-inc.patch
+}
+
+src_compile() {
+ export PATH=$PATH:/opt/xmingw/bin:/opt/xmingw/i386-mingw32msvc/bin
+ unset CFLAGS CXXFLAGS
+
+ RANLIB=i386-mingw32msvc-ranlib \
+ AR=i386-mingw32msvc-ar \
+ AS=i386-mingw32msvc-as \
+ CC=i386-mingw32msvc-gcc \
+ ./configure \
+ --target=i386-mingw32msvc \
+ --prefix=/opt/mingw32/i386-mingw32msvc \
+ || die "configure failed"
+ cd mingwex
+ make W32API_INCLUDE=-I/opt/xmingw/i386-mingw32msvc/include || die
+ cd ..
+ make W32API_INCLUDE=-I/opt/xmingw/i386-mingw32msvc/include || die
+}
+
+src_install() {
+ make install prefix=${D}/opt/xmingw/i386-mingw32msvc \
+ || die "make install failed"
+}