summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2005-11-10 22:22:41 +0000
committerStefan Jones <cretin@gentoo.org>2005-11-10 22:22:41 +0000
commit4482bb9bddf69b9182260bb5ba61180eaff8ad39 (patch)
tree82a12b243c59db567bd14dbc9a48b099866dcee7 /dev-util/xmingw-binutils
parent Stable on alpha wrt security bug #111573 (diff)
downloadgentoo-2-4482bb9bddf69b9182260bb5ba61180eaff8ad39.tar.gz
gentoo-2-4482bb9bddf69b9182260bb5ba61180eaff8ad39.tar.bz2
gentoo-2-4482bb9bddf69b9182260bb5ba61180eaff8ad39.zip
Fix compile with gcc4, bug #112109
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-util/xmingw-binutils')
-rw-r--r--dev-util/xmingw-binutils/ChangeLog8
-rw-r--r--dev-util/xmingw-binutils/files/xmingw-binutils-2.15.94.20050118.1-gcc4.patch60
-rw-r--r--dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild6
3 files changed, 71 insertions, 3 deletions
diff --git a/dev-util/xmingw-binutils/ChangeLog b/dev-util/xmingw-binutils/ChangeLog
index 3d462f1681ef..ecd158c6e48b 100644
--- a/dev-util/xmingw-binutils/ChangeLog
+++ b/dev-util/xmingw-binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/xmingw-binutils
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/ChangeLog,v 1.7 2005/05/27 17:32:05 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/ChangeLog,v 1.8 2005/11/10 22:22:41 cretin Exp $
+
+ 10 Nov 2005; Stefan Jones <cretin@gentoo.org>
+ +files/xmingw-binutils-2.15.94.20050118.1-gcc4.patch,
+ xmingw-binutils-2.15.94.20050118.1.ebuild:
+ Fix compile with gcc4, bug #112109
+ Fix found by Dario Birtic
*xmingw-binutils-2.15.94.20050118.1 (27 May 2005)
diff --git a/dev-util/xmingw-binutils/files/xmingw-binutils-2.15.94.20050118.1-gcc4.patch b/dev-util/xmingw-binutils/files/xmingw-binutils-2.15.94.20050118.1-gcc4.patch
new file mode 100644
index 000000000000..9d0582730d5d
--- /dev/null
+++ b/dev-util/xmingw-binutils/files/xmingw-binutils-2.15.94.20050118.1-gcc4.patch
@@ -0,0 +1,60 @@
+Submitted By: Alexander E. Patrakov
+Date: 2005-10-10
+Initial Package Version: 2.15.94.0.2.2
+Upstream Status: Backport from 2.16.1
+Origin: Alexander E. Patrakov
+Description: Fixes compilation by gcc4 (e.g. from Fedora Core 4 hosts)
+
+--- binutils-2.15.94.0.2.2/gas/tc.h 2004-11-22 20:33:31.000000000 +0000
++++ binutils-2.16.1/gas/tc.h 2005-02-17 13:46:00.000000000 +0000
+@@ -24,25 +25,6 @@
+
+ extern const pseudo_typeS md_pseudo_table[];
+
+-/* JF moved this here from as.h under the theory that nobody except MACHINE.c
+- and write.c care about it anyway. */
+-
+-struct relax_type
+-{
+- /* Forward reach. Signed number. > 0. */
+- long rlx_forward;
+- /* Backward reach. Signed number. < 0. */
+- long rlx_backward;
+-
+- /* Bytes length of this address. */
+- unsigned char rlx_length;
+-
+- /* Next longer relax-state. 0 means there is no 'next' relax-state. */
+- relax_substateT rlx_more;
+-};
+-
+-typedef struct relax_type relax_typeS;
+-
+ extern const int md_reloc_size; /* Size of a relocation record. */
+
+ char * md_atof (int, char *, int *);
+--- binutils-2.15.94.0.2.2/gas/as.h 2004-09-15 19:05:03.000000000 +0000
++++ binutils-2.16.1/gas/as.h 2005-04-13 17:58:40.000000000 +0000
+@@ -397,6 +384,22 @@
+ /* Enough bits for address, but still an integer type.
+ Could be a problem, cross-assembling for 64-bit machines. */
+ typedef addressT relax_addressT;
++
++struct relax_type
++{
++ /* Forward reach. Signed number. > 0. */
++ offsetT rlx_forward;
++ /* Backward reach. Signed number. < 0. */
++ offsetT rlx_backward;
++
++ /* Bytes length of this address. */
++ unsigned char rlx_length;
++
++ /* Next longer relax-state. 0 means there is no 'next' relax-state. */
++ relax_substateT rlx_more;
++};
++
++typedef struct relax_type relax_typeS;
+
+ /* main program "as.c" (command arguments etc). */
+
diff --git a/dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild b/dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild
index 253dda036422..fba071e9de14 100644
--- a/dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild
+++ b/dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild,v 1.1 2005/05/27 17:32:05 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/xmingw-binutils-2.15.94.20050118.1.ebuild,v 1.2 2005/11/10 22:22:41 cretin Exp $
-inherit eutils
+inherit eutils base
MY_P=binutils-2.15.94-20050118-1
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,8 @@ IUSE=""
DEPEND=""
+PATCHES="${FILESDIR}/${P}-gcc4.patch"
+
src_compile() {
./configure \
--target=i386-mingw32msvc \