summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2005-04-13 12:36:47 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2005-04-13 12:36:47 +0000
commita601791491f641a70d2d8b1ae2596d29b6fc1f9e (patch)
tree4f1500e0b4f6c867d551693b749aa46de809f74f /dev-util/subversion/subversion-1.1.4.ebuild
parent4.5.2 updated without version bumping. (diff)
downloadgentoo-2-a601791491f641a70d2d8b1ae2596d29b6fc1f9e.tar.gz
gentoo-2-a601791491f641a70d2d8b1ae2596d29b6fc1f9e.tar.bz2
gentoo-2-a601791491f641a70d2d8b1ae2596d29b6fc1f9e.zip
Revert trapni's broken changes, and do my own version of them
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-util/subversion/subversion-1.1.4.ebuild')
-rw-r--r--dev-util/subversion/subversion-1.1.4.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-util/subversion/subversion-1.1.4.ebuild b/dev-util/subversion/subversion-1.1.4.ebuild
index e4974f1b5a04..9f7eb7a10c6c 100644
--- a/dev-util/subversion/subversion-1.1.4.ebuild
+++ b/dev-util/subversion/subversion-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.4.ebuild,v 1.1 2005/04/05 09:31:50 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.4.ebuild,v 1.2 2005/04/13 12:36:47 pauldv Exp $
inherit elisp-common libtool python eutils bash-completion flag-o-matic depend.apache
@@ -11,7 +11,7 @@ SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="ssl apache2 berkdb python emacs perl java nls"
+IUSE="ssl apache2 berkdb python emacs perl java nls nowebdav"
RESTRICT="maketest"
# Presently subversion doesn't build with swig-1.3.22, bug 65424
@@ -19,7 +19,7 @@ RDEPEND="apache2? ( ${APACHE2_DEPEND} )
>=dev-libs/apr-util-0.9.5
python? ( =dev-lang/swig-1.3.21 >=dev-lang/python-2.0 )
perl? ( =dev-lang/swig-1.3.21 >=dev-lang/perl-5.8 )
- >=net-misc/neon-0.24.7
+ !nowebdav? ( >=net-misc/neon-0.24.7 )
berkdb? ( =sys-libs/db-4* )
java? ( virtual/jdk )
emacs? ( virtual/emacs )"
@@ -83,6 +83,12 @@ src_compile() {
myconf="${myconf} --without-swig"
fi
+ if use nowebdav; then
+ myconf="${myconf} --without-neon"
+ else
+ myconf="${myconf} --with-neon=/usr"
+ fi
+
append-flags `/usr/bin/apr-config --cppflags`
econf ${myconf} \
@@ -92,7 +98,6 @@ src_compile() {
$(use_enable nls) \
--with-apr=/usr \
--with-apr-util=/usr \
- --with-neon=/usr \
--disable-experimental-libtool \
--disable-mod-activation || die "econf failed"