summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-26 07:54:45 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-26 07:54:45 +0000
commit9e5c7f3bfa6d3f7366d023c2e0d6557aa220e267 (patch)
treea4384bc4ff767cd6712cae71ac298fcf2ffb01e0 /dev-util/source-highlight
parentStable for AMD64, wrt bug #414919 (diff)
downloadgentoo-2-9e5c7f3bfa6d3f7366d023c2e0d6557aa220e267.tar.gz
gentoo-2-9e5c7f3bfa6d3f7366d023c2e0d6557aa220e267.tar.bz2
gentoo-2-9e5c7f3bfa6d3f7366d023c2e0d6557aa220e267.zip
Version bump (bug #300540), solves bug #316083 (failing tests) and bug #352005 (broken test with boost-1.45) as well.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/ChangeLog11
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.6.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-util/source-highlight/ChangeLog b/dev-util/source-highlight/ChangeLog
index d74536d9c6e7..bbf0272ffdd4 100644
--- a/dev-util/source-highlight/ChangeLog
+++ b/dev-util/source-highlight/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/source-highlight
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.44 2011/04/10 03:07:43 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.45 2012/05/26 07:54:45 dev-zero Exp $
+
+*source-highlight-3.1.6 (25 May 2012)
+
+ 25 May 2012; Tiziano Müller <dev-zero@gentoo.org>
+ +source-highlight-3.1.6.ebuild:
+ Version bump (bug #300540), solves bug #316083 (failing tests) and bug
+ #352005 (broken test with boost-1.45) as well.
10 Apr 2011; Jonathan Callen <abcd@gentoo.org> source-highlight-3.1.ebuild:
Add prefix support, bump EAPI to 3, add prefix keywords
diff --git a/dev-util/source-highlight/source-highlight-3.1.6.ebuild b/dev-util/source-highlight/source-highlight-3.1.6.ebuild
new file mode 100644
index 000000000000..89b8aabadbc2
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-3.1.6.ebuild,v 1.1 2012/05/26 07:54:45 dev-zero Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 versionator
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="bash-completion doc static-libs"
+
+DEPEND=">=dev-libs/boost-1.49.0
+ dev-util/ctags"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
+ BOOST_VER="$(replace_all_version_separators _ $(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}"))"
+
+ sed -i \
+ -e "s|ac_boost_path_tmp/include|ac_boost_path_tmp/include/boost-${BOOST_VER}|" \
+ configure || die "sed failed"
+
+ econf \
+ --with-boost-regex="boost_regex-mt-${BOOST_VER}" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ DOCS="AUTHORS ChangeLog CREDITS NEWS README THANKS TODO.txt"
+ default
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+
+ use bash-completion && dobashcompletion completion/source-highlight
+
+ # That's not how we want it
+ rm -fr "${ED}/usr/share"/{aclocal,doc}
+ use doc && dohtml -A java doc/*.{html,css,java}
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ default
+}