summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-09-01 23:39:00 +0000
committerMichael Weber <xmw@gentoo.org>2010-09-01 23:39:00 +0000
commit2ae36bcbb90470c71741f8c023f5a2ebf12bd341 (patch)
tree44fcbf74008139979b0cd4e2e31a60e26973e180 /dev-util/redet/redet-8.26.ebuild
parent2.2_rc73 version bump. (diff)
downloadgentoo-2-2ae36bcbb90470c71741f8c023f5a2ebf12bd341.tar.gz
gentoo-2-2ae36bcbb90470c71741f8c023f5a2ebf12bd341.tar.bz2
gentoo-2-2ae36bcbb90470c71741f8c023f5a2ebf12bd341.zip
Version bump to fix bug #335587, added ~amd64.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/redet/redet-8.26.ebuild')
-rw-r--r--dev-util/redet/redet-8.26.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/redet/redet-8.26.ebuild b/dev-util/redet/redet-8.26.ebuild
new file mode 100644
index 000000000000..d7f6caec22ec
--- /dev/null
+++ b/dev-util/redet/redet-8.26.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/redet/redet-8.26.ebuild,v 1.1 2010/09/01 23:39:00 xmw Exp $
+
+DESCRIPTION="A regular expression development and execution tool"
+HOMEPAGE="http://www.billposer.org/Software/redet.html"
+
+SRC_URI="http://www.billposer.org/Software/Downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3
+ dev-tcltk/itk
+ dev-tcltk/iwidgets"
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ local MANUAL_PN=`echo ${PN} | cut -c 1 | tr [:lower:] [:upper:]``echo ${PN} | cut -c 2-`
+
+ newbin ${PN}.tcl ${PN} || die
+
+ insinto /usr/share/applications
+ doins ${PN}.desktop || die
+
+ doman ${PN}.1 || die
+ dodoc AUTHORS CREDITS README-General README-MacOSX \
+ SampleClasses.utf8 \
+ SampleCustomCharacterWidgetDefinition_Armenian \
+ SampleCustomCharacterWidgetDefinition_Greek \
+ SampleNewStyleDotRedetRC_Elaborate SampleNewStyleDotRedetRC_Simple || die
+ dosym doc/${P}/html /usr/share/${MANUAL_PN} || die
+}