summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-02-08 21:09:31 +0000
committerBrian Jackson <iggy@gentoo.org>2004-02-08 21:09:31 +0000
commit4c482f865b0456a081754aeb81d2b5a40ee54675 (patch)
treea411a207947d7f5735e4cca425aba4b87ebf870b /dev-util/rapidsvn
parentnew version #30611 (diff)
downloadgentoo-2-4c482f865b0456a081754aeb81d2b5a40ee54675.tar.gz
gentoo-2-4c482f865b0456a081754aeb81d2b5a40ee54675.tar.bz2
gentoo-2-4c482f865b0456a081754aeb81d2b5a40ee54675.zip
version bump, thanks to jaalexATjasonalexander.us
Diffstat (limited to 'dev-util/rapidsvn')
-rw-r--r--dev-util/rapidsvn/ChangeLog9
-rw-r--r--dev-util/rapidsvn/Manifest2
-rw-r--r--dev-util/rapidsvn/files/digest-rapidsvn-0.5.01
-rw-r--r--dev-util/rapidsvn/rapidsvn-0.5.0.ebuild38
4 files changed, 48 insertions, 2 deletions
diff --git a/dev-util/rapidsvn/ChangeLog b/dev-util/rapidsvn/ChangeLog
index 365d6a420f78..f7e0a8640761 100644
--- a/dev-util/rapidsvn/ChangeLog
+++ b/dev-util/rapidsvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/rapidsvn
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.4 2003/10/17 20:09:43 iggy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.5 2004/02/08 21:09:31 iggy Exp $
+
+*rapidsvn-0.5.0 (08 Feb 2004)
+
+ 08 Feb 2004; Brian Jackson <iggy@gentoo.org> rapidsvn-0.5.0.ebuild:
+ version bump, thanks to jaalexATjasonalexander.us
17 Oct 2003; <iggy@gentoo.org> rapidsvn-0.2.0.ebuild:
remove old versions that depend on ancient versions of subversion
diff --git a/dev-util/rapidsvn/Manifest b/dev-util/rapidsvn/Manifest
index 0e17b8c27a25..a060905c0d52 100644
--- a/dev-util/rapidsvn/Manifest
+++ b/dev-util/rapidsvn/Manifest
@@ -1,4 +1,6 @@
MD5 e69244ad92d8a1ca2849d0d0678c1970 rapidsvn-0.3.0.ebuild 1265
+MD5 4c23c3478c2d38f61f5e3740c9bcff6e rapidsvn-0.5.0.ebuild 1246
MD5 13e7cf55b769f972c285385545039bbd ChangeLog 829
MD5 e8212a950e1f0fccf9fb8f1a7a361c71 metadata.xml 546
MD5 defdae3eecae5fc15f277d890c518416 files/digest-rapidsvn-0.3.0 66
+MD5 f3f2d451769687fbe41d18f69ef60b76 files/digest-rapidsvn-0.5.0 66
diff --git a/dev-util/rapidsvn/files/digest-rapidsvn-0.5.0 b/dev-util/rapidsvn/files/digest-rapidsvn-0.5.0
new file mode 100644
index 000000000000..e3542cf1f1d6
--- /dev/null
+++ b/dev-util/rapidsvn/files/digest-rapidsvn-0.5.0
@@ -0,0 +1 @@
+MD5 fe0e6ec3dffc10784ad583af98cd7968 rapidsvn-0.5.0.tar.gz 482658
diff --git a/dev-util/rapidsvn/rapidsvn-0.5.0.ebuild b/dev-util/rapidsvn/rapidsvn-0.5.0.ebuild
new file mode 100644
index 000000000000..f5912c6a1ba5
--- /dev/null
+++ b/dev-util/rapidsvn/rapidsvn-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.5.0.ebuild,v 1.1 2004/02/08 21:09:31 iggy Exp $
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system."
+HOMEPAGE="http://rapidsvn.tigris.org/"
+SRC_URI="http://www.rapidsvn.org/download/${P}.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="=dev-util/subversion-0.37.0
+ >=x11-libs/wxGTK-2.4.0
+ doc? ( dev-libs/libxslt app-text/docbook-sgml-utils app-doc/doxygen )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # if you compiled subversion without (the) apache2 (flag) and with the berkdb flag
+ # you will get an error that it can't find the lib db4
+ local myconf
+ #needs manpages support in docbook, gentoo doesn't seem to have this - i dunno
+ use doc && myconf="--with-docbook-xsl=/usr/share/sgml/docbook/" \
+ || myconf="--without-xsltproc --without-docbook-xsl --without-doxygen \
+ --without-dot"
+ #README says you have too
+ autoconf configure.in > configure
+ econf --with-svn-lib=/usr/lib \
+ --with-svn-include=/usr/include \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}
+