summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2011-10-27 08:23:03 +0000
committerBrian Harring <ferringb@gentoo.org>2011-10-27 08:23:03 +0000
commit830b6e7d67d1b53b9277b8dfb2cc136fc61e0533 (patch)
treed0595411c86090d35b82e270037de08360b0def4 /dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild
parentadd 0.7.3, remove old versions, drop pyparsing dep (pquery --expr only used i... (diff)
downloadgentoo-2-830b6e7d67d1b53b9277b8dfb2cc136fc61e0533.tar.gz
gentoo-2-830b6e7d67d1b53b9277b8dfb2cc136fc61e0533.tar.bz2
gentoo-2-830b6e7d67d1b53b9277b8dfb2cc136fc61e0533.zip
0.4.15; remove old versions, update for api changes
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild')
-rw-r--r--dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild b/dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild
new file mode 100644
index 000000000000..fa92b25ce12b
--- /dev/null
+++ b/dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/pkgcore-checks-0.4.15.ebuild,v 1.1 2011/10/27 08:23:03 ferringb Exp $
+
+EAPI="3"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="pkgcore developmental repoman replacement"
+HOMEPAGE="http://pkgcore-checks.googlecode.com/"
+SRC_URI="http://pkgcore-checks.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/pkgcore-0.7.3
+ >=dev-python/snakeoil-0.4.4"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS NEWS"
+PYTHON_MODNAME="pkgcore_checks"
+
+pkg_setup() {
+ # disable snakeoil 2to3 caching...
+ unset PY2TO3_CACHEDIR
+ python_pkg_setup
+}
+
+pkg_postinst() {
+ einfo "updating pkgcore plugin cache"
+ pplugincache pkgcore_checks.plugins pkgcore.plugins
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ # Careful not to remove this on up/downgrades.
+ local sitep="${ROOT}$(python_get_sitedir)"
+ if [[ -e "${sitep}/pkgcore_checks/plugins/plugincache2" && ! -e "${sitep}/pkgcore_checks/base.py" ]]; then
+ rm "${sitep}/pkgcore_checks/plugins/plugincache2"
+ fi
+ distutils_pkg_postrm
+}