summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-29 07:58:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-29 07:58:43 +0000
commit3beef0c6dba79593048055eeef4c6e04b5e3ef3f (patch)
tree68661cf78af028166f923a8c9795c4af41b504bc /dev-util/pkgconfig
parentNew package written by me (diff)
downloadgentoo-2-3beef0c6dba79593048055eeef4c6e04b5e3ef3f.tar.gz
gentoo-2-3beef0c6dba79593048055eeef4c6e04b5e3ef3f.tar.bz2
gentoo-2-3beef0c6dba79593048055eeef4c6e04b5e3ef3f.zip
Strip system library directories reliably wrt #512336 by Mike Frysinger
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util/pkgconfig')
-rw-r--r--dev-util/pkgconfig/ChangeLog9
-rw-r--r--dev-util/pkgconfig/files/pkgconfig-0.28-strip_system_library_dirs_reliably.patch30
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.28-r2.ebuild96
-rw-r--r--dev-util/pkgconfig/pkgconfig-9999.ebuild6
4 files changed, 138 insertions, 3 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index 7720a6d3de25..e7a240b6c0a8 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/pkgconfig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.156 2014/07/22 12:41:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.157 2014/07/29 07:58:43 ssuominen Exp $
+
+*pkgconfig-0.28-r2 (29 Jul 2014)
+
+ 29 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/pkgconfig-0.28-strip_system_library_dirs_reliably.patch,
+ +pkgconfig-0.28-r2.ebuild, pkgconfig-9999.ebuild:
+ Strip system library directories reliably wrt #512336 by Mike Frysinger
22 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> -pkgconfig-0.28.ebuild:
old
diff --git a/dev-util/pkgconfig/files/pkgconfig-0.28-strip_system_library_dirs_reliably.patch b/dev-util/pkgconfig/files/pkgconfig-0.28-strip_system_library_dirs_reliably.patch
new file mode 100644
index 000000000000..e1a2bb534a37
--- /dev/null
+++ b/dev-util/pkgconfig/files/pkgconfig-0.28-strip_system_library_dirs_reliably.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/512336
+http://bugs.freedesktop.org/show_bug.cgi?id=78077
+
+From 8691b580ab3f7ac36182060e2253307fbd0aba75 Mon Sep 17 00:00:00 2001
+From: Andrew Oakley <aoakley@espial.com>
+Date: Tue, 29 Apr 2014 13:14:35 +0100
+Subject: [PATCH 1/1] Strip system library directories reliably
+
+This loop was changed from a while loop to a for loop in commit
+9bf6277b, but the iterator is now advanced twice each time round the
+loop.
+---
+ pkg.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/pkg.c b/pkg.c
+index 3697fec..c847c95 100644
+--- a/pkg.c
++++ b/pkg.c
+@@ -917,7 +917,6 @@ verify_package (Package *pkg)
+ }
+ system_dir_iter = system_dir_iter->next;
+ }
+- iter = iter->next;
+ }
+ g_list_free (system_directories);
+
+--
+1.8.3.2
+
diff --git a/dev-util/pkgconfig/pkgconfig-0.28-r2.ebuild b/dev-util/pkgconfig/pkgconfig-0.28-r2.ebuild
new file mode 100644
index 000000000000..90ce7e50479f
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.28-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.28-r2.ebuild,v 1.1 2014/07/29 07:58:43 ssuominen Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic libtool multilib multilib-minimal
+
+MY_P=pkg-config-${PV}
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/pkg-config"
+ inherit autotools git-2
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
+
+RDEPEND="!internal-glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
+ !dev-util/pkgconf[pkg-config]
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-strip_system_library_dirs_reliably.patch
+
+ sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320
+
+ epatch_user
+
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ else
+ elibtoolize # Required for FreeMiNT wrt #333429
+ fi
+}
+
+multilib_src_configure() {
+ local myconf
+
+ if use internal-glib; then
+ myconf+=' --with-internal-glib'
+ # non-glibc platforms use GNU libiconv, but configure needs to
+ # know about that not to get confused when it finds something
+ # outside the prefix too
+ if use prefix && use !elibc_glibc ; then
+ myconf+=" --with-libiconv=gnu"
+ # add the libdir for libtool, otherwise it'll make love with system
+ # installed libiconv
+ append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
+ fi
+ else
+ if ! has_version dev-util/pkgconfig; then
+ export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
+ export GLIB_LIBS="-lglib-2.0"
+ fi
+ fi
+
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+
+ # Force using all the requirements when linking, so that needed -pthread
+ # lines are inherited between libraries
+ use elibc_FreeBSD && myconf+=' --enable-indirect-deps'
+
+ [[ ${PV} == *9999* ]] && myconf+=' --enable-maintainer-mode'
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --with-system-include-path="${EPREFIX}"/usr/include \
+ --with-system-library-path="${EPREFIX}"/usr/$(get_libdir) \
+ ${myconf}
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use prefix; then
+ # Add an explicit reference to $EPREFIX to PKG_CONFIG_PATH to
+ # simplify cross-prefix builds
+ echo "PKG_CONFIG_PATH=${EPREFIX}/usr/$(get_libdir)/pkgconfig:${EPREFIX}/usr/share/pkgconfig" >> "${T}"/99${PN}
+ doenvd "${T}"/99${PN}
+ fi
+}
diff --git a/dev-util/pkgconfig/pkgconfig-9999.ebuild b/dev-util/pkgconfig/pkgconfig-9999.ebuild
index f3ac8f514948..4b8fda17a171 100644
--- a/dev-util/pkgconfig/pkgconfig-9999.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-9999.ebuild,v 1.13 2014/06/24 21:56:52 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-9999.ebuild,v 1.14 2014/07/29 07:58:43 ssuominen Exp $
EAPI=5
-inherit flag-o-matic libtool multilib multilib-minimal
+inherit eutils flag-o-matic libtool multilib multilib-minimal
MY_P=pkg-config-${PV}
@@ -36,6 +36,8 @@ DOCS=( AUTHORS NEWS README )
src_prepare() {
sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320
+ epatch_user
+
if [[ ${PV} == *9999* ]]; then
eautoreconf
else