summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-25 07:33:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-25 07:33:09 +0000
commitc115adecd4487419c0058a9f1ca518ee691a9a49 (patch)
tree2639c5c83c24c07fabdfc59c10d4991a3de20410 /dev-util/pkgconfig-openbsd
parentPrevious was wrong commmit (diff)
downloadgentoo-2-c115adecd4487419c0058a9f1ca518ee691a9a49.tar.gz
gentoo-2-c115adecd4487419c0058a9f1ca518ee691a9a49.tar.bz2
gentoo-2-c115adecd4487419c0058a9f1ca518ee691a9a49.zip
Version bump, keyword for testing, eapi bump, pkg.m4 from pkg-config 0.28, and more
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util/pkgconfig-openbsd')
-rw-r--r--dev-util/pkgconfig-openbsd/ChangeLog11
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130225.ebuild58
2 files changed, 67 insertions, 2 deletions
diff --git a/dev-util/pkgconfig-openbsd/ChangeLog b/dev-util/pkgconfig-openbsd/ChangeLog
index 13fda7482013..fbe5b322c990 100644
--- a/dev-util/pkgconfig-openbsd/ChangeLog
+++ b/dev-util/pkgconfig-openbsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/pkgconfig-openbsd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.9 2012/07/13 09:32:54 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.10 2013/02/25 07:33:09 ssuominen Exp $
+
+*pkgconfig-openbsd-20130225 (25 Feb 2013)
+
+ 25 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +pkgconfig-openbsd-20130225.ebuild:
+ Version bump. Keyword ~əmd64 and ~x86 to get more people test this, not a
+ candidate for stabilization. Use pkg.m4 from pkg-config-0.28.
13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org>
pkgconfig-openbsd-20120710.ebuild:
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130225.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130225.ebuild
new file mode 100644
index 000000000000..63345204cb30
--- /dev/null
+++ b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130225.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130225.ebuild,v 1.1 2013/02/25 07:33:09 ssuominen Exp $
+
+EAPI=5
+
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config
+
+PKG_M4_VERSION=0.28
+
+DESCRIPTION="A perl based version of pkg-config from OpenBSD"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/pkg-config/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz
+ pkg-config? ( http://pkgconfig.freedesktop.org/releases/pkg-config-${PKG_M4_VERSION}.tar.gz )"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pkg-config"
+
+DEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkgconf[pkg-config]
+ )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ # Config.pm from dev-lang/perl doesn't set ARCH, only archname
+ sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
+}
+
+src_install() {
+ if use pkg-config; then
+ dobin usr.bin/pkg-config/pkg-config
+ doman usr.bin/pkg-config/pkg-config.1
+
+ insinto /usr/share/aclocal
+ doins "${WORKDIR}"/pkg-config-*/pkg.m4
+ else
+ newbin usr.bin/pkg-config/pkg-config pkg-config-openbsd
+ newman usr.bin/pkg-config/pkg-config.1 pkg-config-openbsd.1
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r usr.bin/pkg-config/OpenBSD
+
+ cat <<-EOF > "${T}"/99${PN}
+ COLON_SEPARATED=PERL5LIB
+ PERL5LIB=/usr/share/${PN}
+ EOF
+
+ doenvd "${T}"/99${PN}
+}