summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-08-22 04:14:51 +0000
committerDamon Conway <kabau@gentoo.org>2001-08-22 04:14:51 +0000
commit2d4e3e88123051ae60f6b86aaf77365f7736c8c9 (patch)
tree195fb5264790945aef5ab693a37338f6eaf2b25b /dev-util/pccts
parentChanged some insinto and doins to exeinto and doexe for some binary paths. (diff)
downloadgentoo-2-2d4e3e88123051ae60f6b86aaf77365f7736c8c9.tar.gz
gentoo-2-2d4e3e88123051ae60f6b86aaf77365f7736c8c9.tar.bz2
gentoo-2-2d4e3e88123051ae60f6b86aaf77365f7736c8c9.zip
Moving the pccts ebuild from incoming to dev-util. Updated emake and die
syntax. Also updated the install to match the comments.
Diffstat (limited to 'dev-util/pccts')
-rw-r--r--dev-util/pccts/pccts-1.33.24-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/pccts/pccts-1.33.24-r2.ebuild b/dev-util/pccts/pccts-1.33.24-r2.ebuild
new file mode 100644
index 000000000000..0fdceabfe956
--- /dev/null
+++ b/dev-util/pccts/pccts-1.33.24-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Peter Kadau <peter.kadau@web.de>
+# $HEADER$
+
+S=${WORKDIR}/pccts
+DESCRIPTION="An embedded C/C++ parser generator"
+SRC_URI="http://www.polhode.com/pccts133mr24.zip"
+HOMEPAGE="http://www.polhode.com/"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ patch -p0 <${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ emake COPT="${CFLAGS}" || die "compilation failed"
+}
+
+src_install() {
+
+ # main binaries
+ dobin bin/{antlr,dlg,genmk,sor}
+
+ # .c and .cpp files go into /usr/include/pccts also,
+ # because genmk looks for them for being included in output-files
+ # (which are c/c++) generated from grammar-files
+ # right now i include _everything_ just to make sure
+ # it doesn't break pccts-based projects
+ #
+ # if i dive further into the details of genmk.c
+ # it should be possible to put that stuff into /usr/share/pccts
+ #
+ # the M$ and MAC specific stuff gets _not_ included
+ #
+ # main includes
+ insinto /usr/include/pccts
+ doins h/*.{h,c,cpp}
+
+ # sorcerer includes
+ insinto /usr/include/pccts/sorcerer/include
+ doins sorcerer/h/*.{h,c,cpp}
+
+ # sorcerer libraries
+ insinto /usr/include/pccts/sorcerer/lib
+ doins sorcerer/lib/*.{h,c,cpp}
+
+ # documentation
+ # leaving out the M$ and MAC stuff
+ dodoc CHANGES* KNOWN_PROBLEMS* README RIGHTS history.txt history.ps
+ dodoc sorcerer/README sorcerer/UPDATES
+
+ # manual pages
+ doman dlg/dlg.1 antlr/antlr.1
+}