summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-25 13:48:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-25 13:48:01 +0000
commitd91d71f859f9256dd470115ad5bac81bc8db4617 (patch)
tree7f600d8e5967a75b8625fbcf6cbad6072557fdd5 /dev-util/monodevelop-boo
parentRemoved old version (diff)
downloadgentoo-2-d91d71f859f9256dd470115ad5bac81bc8db4617.tar.gz
gentoo-2-d91d71f859f9256dd470115ad5bac81bc8db4617.tar.bz2
gentoo-2-d91d71f859f9256dd470115ad5bac81bc8db4617.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/monodevelop-boo')
-rw-r--r--dev-util/monodevelop-boo/ChangeLog10
-rw-r--r--dev-util/monodevelop-boo/monodevelop-boo-2.2.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-util/monodevelop-boo/ChangeLog b/dev-util/monodevelop-boo/ChangeLog
index c363c21ea0c7..475d606f8e1b 100644
--- a/dev-util/monodevelop-boo/ChangeLog
+++ b/dev-util/monodevelop-boo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/monodevelop-boo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-boo/ChangeLog,v 1.10 2009/10/18 12:17:24 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-boo/ChangeLog,v 1.11 2010/02/25 13:48:01 patrick Exp $
+
+*monodevelop-boo-2.2 (25 Feb 2010)
+
+ 25 Feb 2010; Patrick Lauer <patrick@gentoo.org>
+ +monodevelop-boo-2.2.ebuild:
+ Bump
*monodevelop-boo-2.1.1 (18 Oct 2009)
diff --git a/dev-util/monodevelop-boo/monodevelop-boo-2.2.ebuild b/dev-util/monodevelop-boo/monodevelop-boo-2.2.ebuild
new file mode 100644
index 000000000000..e09499a05850
--- /dev/null
+++ b/dev-util/monodevelop-boo/monodevelop-boo-2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodevelop-boo/monodevelop-boo-2.2.ebuild,v 1.1 2010/02/25 13:48:01 patrick Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Boo Extension for MonoDevelop"
+HOMEPAGE="http://www.monodevelop.com/"
+SRC_URI="http://ftp.novell.com/pub/mono/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/mono-2.4
+ =dev-util/monodevelop-${PV}*
+ >=dev-lang/boo-0.8.2.2960
+ dev-dotnet/gtksourceview-sharp:1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+src_configure() {
+ MD_BOO_CONFIG=""
+ if use debug; then
+ MD_BOO_CONFIG="--config=DEBUG"
+ else
+ MD_BOO_CONFIG="--config=RELEASE"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ ${MD_BOO_CONFIG} \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ mono_multilib_comply
+}