summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-23 19:53:17 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-23 19:53:17 +0000
commit2e2be7683803d696d0f039a4e8a1319ef5467a8d (patch)
tree5f93edc3d7b4859cd09a614edb34ccb51ef925fe /dev-util/mono-tools/files
parentNew ebuild, SVG (1.1 for now) schemas for nxml-mode. (diff)
downloadgentoo-2-2e2be7683803d696d0f039a4e8a1319ef5467a8d.tar.gz
gentoo-2-2e2be7683803d696d0f039a4e8a1319ef5467a8d.tar.bz2
gentoo-2-2e2be7683803d696d0f039a4e8a1319ef5467a8d.zip
Make xulrunner and webkit backends selectable.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-util/mono-tools/files')
-rw-r--r--dev-util/mono-tools/files/mono-tools-2.0-html-renderer-fixes.patch96
1 files changed, 70 insertions, 26 deletions
diff --git a/dev-util/mono-tools/files/mono-tools-2.0-html-renderer-fixes.patch b/dev-util/mono-tools/files/mono-tools-2.0-html-renderer-fixes.patch
index 283f9326e347..bed777f45585 100644
--- a/dev-util/mono-tools/files/mono-tools-2.0-html-renderer-fixes.patch
+++ b/dev-util/mono-tools/files/mono-tools-2.0-html-renderer-fixes.patch
@@ -1,22 +1,21 @@
-diff -urN mono-tools-2.0.old/configure.in mono-tools-2.0/configure.in
---- mono-tools-2.0.old/configure.in 2008-10-15 11:48:22.000000000 +0200
-+++ mono-tools-2.0/configure.in 2008-10-15 12:09:00.000000000 +0200
-@@ -46,26 +46,40 @@
+diff -NrU5 mono-tools-2.0.orig/configure.in mono-tools-2.0/configure.in
+--- mono-tools-2.0.orig/configure.in 2008-11-23 20:37:03.000000000 +0100
++++ mono-tools-2.0/configure.in 2008-11-23 20:38:00.000000000 +0100
+@@ -43,33 +43,49 @@
+
+ PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 glade-sharp-2.0 gnome-sharp-2.0 gconf-sharp-2.0)
+ #PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp glade-sharp gconf-sharp)
AC_SUBST(GTK_SHARP_LIBS)
- PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-3.14, enable_gtkhtml=yes, enable_gtkhtml=no)
+-PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-3.14, enable_gtkhtml=yes, enable_gtkhtml=no)
-if test "x$enable_gtkhtml" = "xyes"; then
-CSHARP_FLAGS="-d:GTKHTML_SHARP_3_14"
-else
-PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-2.0, enable_gtkhtml=yes, enable_gtkhtml=no)
-CSHARP_FLAGS=
-+dnl PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-3.14, enable_gtkhtml=yes, enabl e_gtkhtml=no)
-+dnl if test "x$enable_gtkhtml" = "xyes"; then
-+dnl CSHARP_FLAGS="-d:GTKHTML_SHARP_3_14"
-+dnl else
+AC_ARG_ENABLE(gtkhtml,
-+ AC_HELP_STRING([--enable-gtkhtml], [Use GTKHTML Browser]),,
-+ enable_gtkhtml=yes)
++ AC_HELP_STRING([--enable-gtkhtml], [Use GTKHTML Browser]),,
++ enable_gtkhtml=yes)
+
+if test "x$enable_gtkhtml" = "xyes" ; then
+ PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-2.0)
@@ -26,23 +25,23 @@ diff -urN mono-tools-2.0.old/configure.in mono-tools-2.0/configure.in
fi
-AC_SUBST(GTKHTML_SHARP_LIBS)
-AC_SUBST(CSHARP_FLAGS)
--AM_CONDITIONAL(ENABLE_GTKHTML, test "x$enable_gtkhtml" = "xyes")
+dnl fi
++
+ AM_CONDITIONAL(ENABLE_GTKHTML, test "x$enable_gtkhtml" = "xyes")
-PKG_CHECK_MODULES(GECKO_SHARP, gecko-sharp-2.0, enable_gecko=yes, enable_gecko=no)
-AC_SUBST(GECKO_SHARP_LIBS)
-AM_CONDITIONAL(ENABLE_GECKO, test "x$enable_gecko" = "xyes")
-+AM_CONDITIONAL(ENABLE_GTKHTML, test "x$enable_gtkhtml" = "xyes")
-
+-
-if test "x$enable_gecko" = "xyes"; then
- # get the mozilla home directory
- MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
- AC_SUBST(MOZILLA_HOME)
+AC_ARG_ENABLE(mozilla,
-+ AC_HELP_STRING([--enable-mozilla], [Use Gecko Browser]),,
-+ enable_gecko=yes)
++ AC_HELP_STRING([--enable-mozilla], [Use Mozilla browser]),,
++ enable_mozilla=yes)
+
-+if test "x$enable_gecko"= "xyes" ; then
++if test "x$enable_mozilla" = "xyes" ; then
+ PKG_CHECK_MODULES(GECKO_SHARP, gecko-sharp-2.0)
+
+ AC_SUBST(GECKO_SHARP_LIBS)
@@ -50,17 +49,60 @@ diff -urN mono-tools-2.0.old/configure.in mono-tools-2.0/configure.in
+ # get the mozilla home directory
+ MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
+ AC_SUBST(MOZILLA_HOME)
++fi
++
++AM_CONDITIONAL(ENABLE_GECKO, test "x$enable_mozilla" = "xyes")
++
++AC_ARG_ENABLE(webkit,
++ AC_HELP_STRING([--enable-webkit], [Use Webkit browser]),,
++ enable_mozilla=yes)
++
++if test "x$enable_webkit" = "xyes" ; then
++ PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0)
++ AC_SUBST(WEBKIT_SHARP_LIBS)
fi
-+AM_CONDITIONAL(ENABLE_GECKO, test "x$enable_gecko" = "xyes")
-+
- PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0, enable_webkit=yes, enable_webkit=no)
- AC_SUBST(WEBKIT_SHARP_LIBS)
+-PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0, enable_webkit=yes, enable_webkit=no)
+-AC_SUBST(WEBKIT_SHARP_LIBS)
AM_CONDITIONAL(ENABLE_WEBKIT, test "x$enable_webkit" = "xyes")
-diff -urN mono-tools-2.0.old/docbrowser/monodoc.in mono-tools-2.0/docbrowser/monodoc.in
---- mono-tools-2.0.old/docbrowser/monodoc.in 2008-10-15 12:09:36.000000000 +0200
-+++ mono-tools-2.0/docbrowser/monodoc.in 2008-10-15 12:12:33.000000000 +0200
-@@ -86,8 +86,10 @@
+
+ # PKG_CHECK_MODULES(MONOWEBBROWSER, mono-webbrowser, enable_monowebbrowser=yes, enable_monowebbrowser=no)
+ # AC_SUBST(MONOWEBBROWSER_LIBS)
+
+@@ -89,12 +105,12 @@
+ fi
+ fi
+ MONOWEBBROWSER_LIBS=-r:Mono.WebBrowser
+ AM_CONDITIONAL(ENABLE_MONOWEBBROWSER, test "x$enable_monowebbrowser" = "xyes")
+
+-if test "x$enable_gtkhtml$enable_gecko$enable_monowebbrowser$enable_webkit" = "xnononono" ; then
+- AC_MSG_ERROR([no HTML display found. You need either gtkhtml, gecko, WebKit or Mono.WebBrowser])
++if test "x$enable_gtkhtml$enable_mozilla$enable_monowebbrowser$enable_webkit" = "xnononono" ; then
++ AC_MSG_ERROR([no HTML display found. You need either gtkhtml, mozilla, WebKit or Mono.WebBrowser])
+ fi
+
+ AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [Use 'DEBUG' Configuration [default=YES]]),
+@@ -232,11 +248,11 @@
+
+ echo "---"
+ echo "Configuration summary"
+ echo ""
+ echo " * Installation prefix = $prefix"
+-echo " * Using Gecko = $enable_gecko"
++echo " * Using Mozilla = $enable_mozilla"
+ echo " * Using GtkHtml = $enable_gtkhtml"
+ echo " * Using Mono.WebBrowser = $enable_monowebbrowser"
+ echo " * Using WebKit = $enable_webkit"
+ echo ""
+ echo " NOTE: if any of the above say 'no' you may install the"
+diff -NrU5 mono-tools-2.0.orig/docbrowser/monodoc.in mono-tools-2.0/docbrowser/monodoc.in
+--- mono-tools-2.0.orig/docbrowser/monodoc.in 2008-11-23 20:37:03.000000000 +0100
++++ mono-tools-2.0/docbrowser/monodoc.in 2008-11-23 20:35:14.000000000 +0100
+@@ -84,12 +84,14 @@
+ elif [ $(which xulrunner 2> /dev/null) ] > /dev/null ; then
+ MOZILLA_FIVE_HOME=`getdirectory xulrunner`
MOZILLA_HOME=$MOZILLA_FIVE_HOME
elif [ $(which mozilla 2> /dev/null) ] && grep MOZILLA_FIVE_HOME= "$(which mozilla)" > /dev/null ; then
MOZILLA_HOME=$(grep MOZILLA_FIVE_HOME= $(which mozilla) | cut -d '"' -f 2)
@@ -68,8 +110,10 @@ diff -urN mono-tools-2.0.old/docbrowser/monodoc.in mono-tools-2.0/docbrowser/mon
- MOZILLA_HOME=$(grep MOZILLA_FIVE_HOME= $(which firefox) | cut -d '"' -f 2)
+elif [ $(which firefox 2> /dev/null) ] && grep MOZILLA_LIBDIR= "$(which firefox)" > /dev/null ; then
+ MOZILLA_HOME=$(grep MOZILLA_LIBDIR= $(which firefox) | cut -d '=' -f 2)
-+elif [ $(which seamonkey 2> /dev/null) ] && grep MOZILLA_LIBDIR= "$(which seamonke y)" > /dev/null ; then
++elif [ $(which seamonkey 2> /dev/null) ] && grep MOZILLA_LIBDIR= "$(which seamonkey)" > /dev/null ; then
+ MOZILLA_HOME=$(grep MOZILLA_LIBDIR= $(which seamonkey) | cut -d '=' -f 2)
fi
if [ -n $LD_LIBRARY_PATH ]; then
+ export LD_LIBRARY_PATH=$MOZILLA_HOME:$LD_LIBRARY_PATH
+ else