summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-08 19:33:13 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-08 19:33:13 +0000
commit7b0dac66bf570965f4202eaf3b7d3e1be6f954e2 (patch)
tree3ec88e39a38f950b25a1e2c6354ade020c28b41b /dev-util/meld
parentnew package, gnome2 diff/merge tool (diff)
downloadgentoo-2-7b0dac66bf570965f4202eaf3b7d3e1be6f954e2.tar.gz
gentoo-2-7b0dac66bf570965f4202eaf3b7d3e1be6f954e2.tar.bz2
gentoo-2-7b0dac66bf570965f4202eaf3b7d3e1be6f954e2.zip
new package, gnome2 diff/merge tool
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/ChangeLog10
-rw-r--r--dev-util/meld/Manifest3
-rw-r--r--dev-util/meld/files/digest-meld-0.8.11
-rw-r--r--dev-util/meld/files/meld-0.8.1-gentoo.diff47
-rw-r--r--dev-util/meld/meld-0.8.1.ebuild38
5 files changed, 98 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
new file mode 100644
index 000000000000..bbb4ebaf7d3c
--- /dev/null
+++ b/dev-util/meld/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/meld
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.1 2003/06/08 19:33:05 liquidx Exp $
+
+*meld-0.8.1 (08 Jun 2003)
+
+ 08 Jun 2003; Alastair Tse <liquidx@gentoo.org> meld-0.8.1.ebuild,
+ files/meld-0.8.1-gentoo.diff:
+ new package. thanks to suka <suka@t0.or.at> (#21578)
+
diff --git a/dev-util/meld/Manifest b/dev-util/meld/Manifest
index 5234cab7b63c..7465f6ef062a 100644
--- a/dev-util/meld/Manifest
+++ b/dev-util/meld/Manifest
@@ -1,3 +1,4 @@
-MD5 d0138fb8168117f15b92bf8cb254644d meld-0.8.1.ebuild 862
+MD5 ffb236603fbdb43657048801a2ee5e0a meld-0.8.1.ebuild 957
+MD5 922556839f0e4c23156297b5cfdfb12f ChangeLog 392
MD5 774e0a890077f2d11ffba5afb4dd8dee files/meld-0.8.1-gentoo.diff 1443
MD5 c99fc566baf1043d1736556c5b31357d files/digest-meld-0.8.1 58
diff --git a/dev-util/meld/files/digest-meld-0.8.1 b/dev-util/meld/files/digest-meld-0.8.1
new file mode 100644
index 000000000000..efcfa6ff0dcc
--- /dev/null
+++ b/dev-util/meld/files/digest-meld-0.8.1
@@ -0,0 +1 @@
+MD5 7c45bae3f0ddb50834722502fa40a7d6 meld-0.8.1.tgz 72491
diff --git a/dev-util/meld/files/meld-0.8.1-gentoo.diff b/dev-util/meld/files/meld-0.8.1-gentoo.diff
new file mode 100644
index 000000000000..84b6666e28b8
--- /dev/null
+++ b/dev-util/meld/files/meld-0.8.1-gentoo.diff
@@ -0,0 +1,47 @@
+--- meld-0.8.1.orig/meld
++++ meld-0.8.1/meld
+@@ -52,6 +52,12 @@
+ print "Due to incompatible API changes some functions may not operate as expected."
+
+ #
++# Add the library path to the system load path
++#
++import os
++sys.path = [os.curdir, '/usr/lib/meld'] + sys.path
++
++#
+ # main
+ #
+ import meldapp
+--- meld-0.8.1.orig/meld.desktop
++++ meld-0.8.1/meld.desktop
+@@ -6,6 +6,6 @@
+ Comment=Compare and merge your files.
+ TryExec=meld
+ Exec=meld
+-Path=/home/stephen/Projects/meld
+ Terminal=false
+ Categories=GNOME;Application;Development;
++Icon=/usr/share/meld/glade2/pixmaps/icon.png
+--- meld-0.8.1.orig/meldapp.py
++++ meld-0.8.1/meldapp.py
+@@ -441,7 +441,7 @@
+ gnome.url_show("http://meld.sourceforge.net")
+
+ def on_menu_users_manual_activate(self, button):
+- gnome.url_show("file:///"+os.path.abspath(misc.appdir("manual/index.html") ) )
++ gnome.url_show("file:///usr/share/doc/meld-0.8.1/html/index.html")
+
+ def on_menu_about_activate(self, *extra):
+ about = gtk.glade.XML(misc.appdir("glade2/meld-app.glade"),"about").get_widget("about")
+--- meld-0.8.1.orig/misc.py
++++ meld-0.8.1/misc.py
+@@ -27,7 +27,7 @@
+ def appdir(path):
+ """Return where the application is installed.
+ """
+- return os.path.join( os.path.dirname(sys.argv[0]), path )
++ return os.path.join( "/usr/share/meld", path )
+
+ class struct:
+ """Similar to a dictionary except that members may be accessed as s.member.
diff --git a/dev-util/meld/meld-0.8.1.ebuild b/dev-util/meld/meld-0.8.1.ebuild
new file mode 100644
index 000000000000..7f13b1c013d6
--- /dev/null
+++ b/dev-util/meld/meld-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-0.8.1.ebuild,v 1.1 2003/06/08 19:33:05 liquidx Exp $
+
+DESCRIPTION="A graphical (GNOME 2) diff and merge tool"
+HOMEPAGE="http://meld.sourceforge.net/"
+SRC_URI="mirror://sourceforge/meld/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=dev-python/gnome-python-1.99.15
+ >=dev-python/pygtk-1.99.15
+ >=dev-python/orbit-python-1.99.0"
+
+src_unpack(){
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_install() {
+ insinto /usr/lib/meld
+ doins *.py
+ dobin meld
+ insinto /usr/share/meld/glade2
+ doins glade2/*
+ insinto /usr/share/meld/glade2/pixmaps
+ doins glade2/pixmaps/*
+ insinto /usr/share/applications
+ doins meld.desktop
+ dodoc AUTHORS COPYING INSTALL TODO.txt
+ dohtml manual/*
+}