summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-29 22:52:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-29 22:52:52 +0000
commitc20849925f2cf0005311b1e52f2201c2d2ade0b5 (patch)
treea3bb3da07c8d19574b67499e603d9c77fba8b6ae /dev-util/kelbt/kelbt-0.13.ebuild
parenta dingo ate my changelog (diff)
downloadgentoo-2-c20849925f2cf0005311b1e52f2201c2d2ade0b5.tar.gz
gentoo-2-c20849925f2cf0005311b1e52f2201c2d2ade0b5.tar.bz2
gentoo-2-c20849925f2cf0005311b1e52f2201c2d2ade0b5.zip
Fix install and respect flags.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kelbt/kelbt-0.13.ebuild')
-rw-r--r--dev-util/kelbt/kelbt-0.13.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/kelbt/kelbt-0.13.ebuild b/dev-util/kelbt/kelbt-0.13.ebuild
index b96c84bd83af..2c84f9709b40 100644
--- a/dev-util/kelbt/kelbt-0.13.ebuild
+++ b/dev-util/kelbt/kelbt-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kelbt/kelbt-0.13.ebuild,v 1.1 2009/05/19 19:45:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kelbt/kelbt-0.13.ebuild,v 1.2 2009/05/29 22:52:52 flameeyes Exp $
EAPI=2
@@ -26,13 +26,17 @@ src_prepare() {
{} \;
}
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
src_test() {
cd "${S}"/test
./runtests || die "tests failed"
}
src_install() {
- dobin kelbt || die
+ dobin kelbt/kelbt || die
dodoc TODO CREDITS ChangeLog || die
if use vim-syntax; then