summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-11-23 03:46:41 +0000
committerJeroen Roovers <jer@gentoo.org>2009-11-23 03:46:41 +0000
commit687d200ca8122564fd95f4ec55b9ebf743529d22 (patch)
tree5bcf105559b98ef5c64fcb97e5627dc603fc9c49 /dev-util/indent
parentstrip-flags for bug #293927 (diff)
downloadgentoo-2-687d200ca8122564fd95f4ec55b9ebf743529d22.tar.gz
gentoo-2-687d200ca8122564fd95f4ec55b9ebf743529d22.tar.bz2
gentoo-2-687d200ca8122564fd95f4ec55b9ebf743529d22.zip
Update license. Do apply the Makefile.am patch because we do need to update the (empty) man file (thanks to Drake Wyrm (bug #76610). At the same time, do not install the undocumented texinfo2man. Bumping because we do need to get the man page out there and because perhaps people want texinfo2man after all.
(Portage version: 2.2_rc51/cvs/Linux i686)
Diffstat (limited to 'dev-util/indent')
-rw-r--r--dev-util/indent/ChangeLog12
-rw-r--r--dev-util/indent/files/2.2.10-man.patch22
-rw-r--r--dev-util/indent/indent-2.2.10-r1.ebuild40
-rw-r--r--dev-util/indent/indent-2.2.10.ebuild4
4 files changed, 75 insertions, 3 deletions
diff --git a/dev-util/indent/ChangeLog b/dev-util/indent/ChangeLog
index 996fd9342753..ade970562cb3 100644
--- a/dev-util/indent/ChangeLog
+++ b/dev-util/indent/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-util/indent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/ChangeLog,v 1.35 2009/10/28 01:36:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/ChangeLog,v 1.36 2009/11/23 03:46:41 jer Exp $
+
+*indent-2.2.10-r1 (23 Nov 2009)
+
+ 23 Nov 2009; Jeroen Roovers <jer@gentoo.org> +files/2.2.10-man.patch,
+ indent-2.2.10.ebuild, +indent-2.2.10-r1.ebuild:
+ Update license. Do apply the Makefile.am patch because we do need to
+ update the (empty) man file (thanks to Drake Wyrm (bug #76610). At the
+ same time, do not install the undocumented texinfo2man. Bumping because we
+ do need to get the man page out there and because perhaps people want
+ texinfo2man after all.
*indent-2.2.10 (28 Oct 2009)
diff --git a/dev-util/indent/files/2.2.10-man.patch b/dev-util/indent/files/2.2.10-man.patch
new file mode 100644
index 000000000000..1546f69bb931
--- /dev/null
+++ b/dev-util/indent/files/2.2.10-man.patch
@@ -0,0 +1,22 @@
+* Set EXTRA_PROGRAMS to build texinfo2man but not install it.
+* Make sure it's built before it's used (thanks to Drake Wyrm).
+
+
+--- indent-2.2.10/man/Makefile.am.orig 2008-03-11 19:50:42.000000000 +0100
++++ indent-2.2.10/man/Makefile.am 2009-11-23 04:11:17.000000000 +0100
+@@ -1,6 +1,6 @@
+ mandir = @mandir@
+
+-bin_PROGRAMS = texinfo2man
++EXTRA_PROGRAMS = texinfo2man
+ texinfo2man_SOURCES = texinfo2man.c
+ man_MANS = @PACKAGE@.1
+
+@@ -10,6 +10,6 @@
+
+ MAINTAINERCLEANFILES = @PACKAGE@.1 Makefile.in texinfo2man
+
+-@PACKAGE@.1: ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo texinfo2man.c Makefile.am
++@PACKAGE@.1: ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo texinfo2man Makefile.am
+ ./texinfo2man ${srcdir}/@PACKAGE@.1.in ${srcdir}/../doc/@PACKAGE@.texinfo > $@
+
diff --git a/dev-util/indent/indent-2.2.10-r1.ebuild b/dev-util/indent/indent-2.2.10-r1.ebuild
new file mode 100644
index 000000000000..8ec45069be18
--- /dev/null
+++ b/dev-util/indent/indent-2.2.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.10-r1.ebuild,v 1.1 2009/11/23 03:46:41 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
+SRC_URI="mirror://gnu/indent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ # Fix parallel make issue in man/ (bug #76610)
+ # and do not install texinfo2man
+ epatch "${FILESDIR}"/${PV}-man.patch
+ eautoreconf
+}
+
+src_configure() {
+ # LINGUAS is used in aclocal.m4 (bug #94837)
+ unset LINGUAS
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldir="/usr/share/doc/${PF}/html" \
+ install || die "make install failed"
+ dodoc AUTHORS NEWS README* ChangeLog*
+}
diff --git a/dev-util/indent/indent-2.2.10.ebuild b/dev-util/indent/indent-2.2.10.ebuild
index d0dca35fe51d..1a8ce3c5ed31 100644
--- a/dev-util/indent/indent-2.2.10.ebuild
+++ b/dev-util/indent/indent-2.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.10.ebuild,v 1.1 2009/10/28 01:36:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.10.ebuild,v 1.2 2009/11/23 03:46:41 jer Exp $
EAPI="2"
@@ -10,7 +10,7 @@ DESCRIPTION="Indent program source files"
HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
SRC_URI="mirror://gnu/indent/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="nls"