summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-23 04:31:47 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-23 04:31:47 +0000
commitf0df9e0eb8ff52d1bae671954347d80d809831fe (patch)
tree6287f38b2cf758aa61973151fab8942d98afd049 /dev-util/hxd
parentVersion bump - only small compiler warning fixes. Add a long description for ... (diff)
downloadgentoo-2-f0df9e0eb8ff52d1bae671954347d80d809831fe.tar.gz
gentoo-2-f0df9e0eb8ff52d1bae671954347d80d809831fe.tar.bz2
gentoo-2-f0df9e0eb8ff52d1bae671954347d80d809831fe.zip
Version bump, Respecting CFLAGS, LDFLAGS and CC variable, Fixing pre-stripped files, Workaround for parallel make
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-util/hxd')
-rw-r--r--dev-util/hxd/ChangeLog12
-rw-r--r--dev-util/hxd/hxd-0.70.02.ebuild39
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/hxd/ChangeLog b/dev-util/hxd/ChangeLog
index fdf32aaf9764..5b7998e6b69f 100644
--- a/dev-util/hxd/ChangeLog
+++ b/dev-util/hxd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/hxd
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/hxd/ChangeLog,v 1.9 2008/12/27 05:46:19 wormo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/hxd/ChangeLog,v 1.10 2009/08/23 04:31:47 vostorga Exp $
+
+*hxd-0.70.02 (23 Aug 2009)
+
+ 23 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> +hxd-0.70.02.ebuild:
+ Version bump to 0.70.02
+ Respecting CFLAGS, LDFLAGS and CC variable
+ Fixing pre-stripped files
+ Workaround for parallel make
27 Dec 2008; Stephanie Lockwood-Childs <wormo@gentoo.org> hxd-0.70.ebuild:
add ~amd64 keyword, reporter Andrew Savchenko (bug #252644)
diff --git a/dev-util/hxd/hxd-0.70.02.ebuild b/dev-util/hxd/hxd-0.70.02.ebuild
new file mode 100644
index 000000000000..73225e05c382
--- /dev/null
+++ b/dev-util/hxd/hxd-0.70.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/hxd/hxd-0.70.02.ebuild,v 1.1 2009/08/23 04:31:47 vostorga Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Binary to hexadecimal converter"
+HOMEPAGE="http://www-tet.ee.tu-berlin.de/solyga/linux/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~mips ~ppc"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #Respect FLAGS and avoid stripping
+ sed -i -e "/^CFLAGS/s|=|+=|" \
+ -e "/^LDFLAGS/s|=|+=|" \
+ -e "/^LDFLAGS/s|-s||" \
+ -e "s/install -s/install/" \
+ Makefile.Linux || die "sed failed"
+}
+
+src_compile() {
+ econf || die
+ emake CC="$(tc-getCC)" -j1 || die "make failed"
+}
+
+src_install() {
+ dobin hxd unhxd
+ doman hxd.1 unhxd.1
+ dodoc README TODO
+}