summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-07-31 19:37:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-07-31 19:37:18 +0000
commitb4c00efe8084e1f73b6fc5391bbc6e17ece332c6 (patch)
tree228f6f2cf8264546e5730e91c9780ee7305882bf /dev-util/google-perftools
parentStable for HPPA (bug #374681). (diff)
downloadgentoo-2-b4c00efe8084e1f73b6fc5391bbc6e17ece332c6.tar.gz
gentoo-2-b4c00efe8084e1f73b6fc5391bbc6e17ece332c6.tar.bz2
gentoo-2-b4c00efe8084e1f73b6fc5391bbc6e17ece332c6.zip
Version bump; thanks to Pavel Stratil in bug #376493.
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/ChangeLog8
-rw-r--r--dev-util/google-perftools/google-perftools-1.8.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/google-perftools/ChangeLog b/dev-util/google-perftools/ChangeLog
index c50a12511436..d2789426759f 100644
--- a/dev-util/google-perftools/ChangeLog
+++ b/dev-util/google-perftools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/google-perftools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.8 2011/03/06 12:50:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.9 2011/07/31 19:37:18 flameeyes Exp $
+
+*google-perftools-1.8 (31 Jul 2011)
+
+ 31 Jul 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +google-perftools-1.8.ebuild:
+ Version bump; thanks to Pavel Stratil in bug #376493.
*google-perftools-1.7 (06 Mar 2011)
diff --git a/dev-util/google-perftools/google-perftools-1.8.ebuild b/dev-util/google-perftools/google-perftools-1.8.ebuild
new file mode 100644
index 000000000000..aa07abf7a67d
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-1.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.8.ebuild,v 1.1 2011/07/31 19:37:18 flameeyes Exp $
+
+EAPI=4
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="http://code.google.com/p/google-perftools/"
+SRC_URI="http://google-perftools.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="largepages +debug minimal" # test"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+# tests end up in an infinite loop, even without sandbox
+RESTRICT=test
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+
+ # use test && \
+ makeopts="${makeopts} noinst_PROGRAMS= "
+
+ # don't install _anything_ from the documentation, since it would
+ # install it in non-standard locations, and would just waste time.
+ makeopts="${makeopts} dist_doc_DATA= "
+}
+
+src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ $(use_enable debug debugalloc) \
+ $(use_enable minimal)
+}
+
+src_compile() {
+ emake ${makeopts} || die "emake failed"
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sanbox is enabled."
+ ewarn "See http://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install ${makeopts} || die "emake install failed"
+
+ # Remove libtool files since we dropped the static libraries
+ find "${D}" -name '*.la' -delete
+
+ dodoc README AUTHORS ChangeLog TODO NEWS || die
+ pushd doc
+ dohtml -r * || die
+ popd
+}