summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-13 20:04:50 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-13 20:04:50 +0000
commitd39fcaff92fa19e1ada179a424887008991531c4 (patch)
tree1ffb796a0935a9d9c8e6888d394c3b11c44f67ca /dev-util/gob/gob-2.0.5.ebuild
parentcorrected LICENSE (diff)
downloadgentoo-2-d39fcaff92fa19e1ada179a424887008991531c4.tar.gz
gentoo-2-d39fcaff92fa19e1ada179a424887008991531c4.tar.bz2
gentoo-2-d39fcaff92fa19e1ada179a424887008991531c4.zip
version bump
Diffstat (limited to 'dev-util/gob/gob-2.0.5.ebuild')
-rw-r--r--dev-util/gob/gob-2.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/gob/gob-2.0.5.ebuild b/dev-util/gob/gob-2.0.5.ebuild
new file mode 100644
index 000000000000..963c1446547c
--- /dev/null
+++ b/dev-util/gob/gob-2.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/gob-2.0.5.ebuild,v 1.1 2003/03/13 20:04:50 liquidx Exp $
+
+MY_P=${PN}2-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GOB is a preprocessor for making GTK+ objects with inline C code"
+SRC_URI="http://ftp.5z.com/pub/gob/${MY_P}.tar.gz"
+HOMEPAGE="http://www.5z.com/jirka/gob.html"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+RDEPEND=">=dev-libs/glib-2.0*
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_compile() {
+ econf || die "configure fail"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING COPYING.generated-code ChangeLog NEWS README TODO
+}