summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-14 02:43:12 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-14 02:43:12 +0000
commitb3685aff807932db1722d5a6ddc8e783a5b527a0 (patch)
treea76afd99dd3ecb4299e8eea49bf01c6d872ab44b /dev-util/ghh/ghh-9999.ebuild
parentChange metadata. (diff)
downloadgentoo-2-b3685aff807932db1722d5a6ddc8e783a5b527a0.tar.gz
gentoo-2-b3685aff807932db1722d5a6ddc8e783a5b527a0.tar.bz2
gentoo-2-b3685aff807932db1722d5a6ddc8e783a5b527a0.zip
Initial import. Ebuild by me.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-util/ghh/ghh-9999.ebuild')
-rw-r--r--dev-util/ghh/ghh-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/ghh/ghh-9999.ebuild b/dev-util/ghh/ghh-9999.ebuild
new file mode 100644
index 000000000000..2385f757c88a
--- /dev/null
+++ b/dev-util/ghh/ghh-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ghh/ghh-9999.ebuild,v 1.1 2008/01/14 02:43:12 vapier Exp $
+
+EGIT_REPO_URI="http://jean-francois.richard.name/ghh.git"
+inherit git autotools
+
+DESCRIPTION="a tool to track the history and make backups of your home directory"
+HOMEPAGE="http://jean-francois.richard.name/ghh/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# probably needs more/less crap listed here ...
+RDEPEND="=x11-libs/gtk+-2*
+ =dev-libs/glib-2*
+ =gnome-base/libgnome-2*
+ app-text/gnome-doc-utils
+ dev-util/git
+ dev-lang/python"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+ NOCONFIGURE=yes ./autogen.sh || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TODO
+}