summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-07-04 23:45:33 +0000
committerMarius Mauch <genone@gentoo.org>2004-07-04 23:45:33 +0000
commit3a222eb06a2b9945bf4552eb64ab736fabbed10f (patch)
tree6f710d757fd824444b7d846e694c1906dfcb13f1 /dev-util/gambas/files
parentfix bug #55634. (Manifest recommit) (diff)
downloadgentoo-2-3a222eb06a2b9945bf4552eb64ab736fabbed10f.tar.gz
gentoo-2-3a222eb06a2b9945bf4552eb64ab736fabbed10f.tar.bz2
gentoo-2-3a222eb06a2b9945bf4552eb64ab736fabbed10f.zip
version bump
Diffstat (limited to 'dev-util/gambas/files')
-rw-r--r--dev-util/gambas/files/WebHome.html18
-rw-r--r--dev-util/gambas/files/digest-gambas-0.941
-rw-r--r--dev-util/gambas/files/digest-gambas-0.94a1
-rw-r--r--dev-util/gambas/files/non-symlink-0.94.patch115
4 files changed, 134 insertions, 1 deletions
diff --git a/dev-util/gambas/files/WebHome.html b/dev-util/gambas/files/WebHome.html
new file mode 100644
index 000000000000..2c5d0c6b43b8
--- /dev/null
+++ b/dev-util/gambas/files/WebHome.html
@@ -0,0 +1,18 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
+<!--<link rel="stylesheet" href=".rsrc/WebHome/../style.css">-->
+
+<head>
+ <title> Gambas-Wiki . Gambas . WebHome</title>
+ <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+ <meta name="robots" content="noindex" />
+
+</head>
+<body bgcolor="#ffffff">
+
+<h1><a name="Gambas_Documentation"> Gambas Documentation </a></h1>
+
+<p>Sorry, but to get the API documentation you have to set the <b>doc</b> USE-flag
+in make.conf or package.use (see <i>man portage</i>).</p>
+
+</body></html>
diff --git a/dev-util/gambas/files/digest-gambas-0.94 b/dev-util/gambas/files/digest-gambas-0.94
deleted file mode 100644
index 3444423deeed..000000000000
--- a/dev-util/gambas/files/digest-gambas-0.94
+++ /dev/null
@@ -1 +0,0 @@
-MD5 538f603bd7561c4a078393002cd3c47d gambas-0.94.tar.bz2 3692414
diff --git a/dev-util/gambas/files/digest-gambas-0.94a b/dev-util/gambas/files/digest-gambas-0.94a
new file mode 100644
index 000000000000..d6643696dd92
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.94a
@@ -0,0 +1 @@
+MD5 00e9e481bd1d9069aad124b21f06e110 gambas-0.94a.tar.bz2 3700855
diff --git a/dev-util/gambas/files/non-symlink-0.94.patch b/dev-util/gambas/files/non-symlink-0.94.patch
new file mode 100644
index 000000000000..c3c718807e0b
--- /dev/null
+++ b/dev-util/gambas/files/non-symlink-0.94.patch
@@ -0,0 +1,115 @@
+--- src/comp/Makefile.am.org 2004-07-01 20:43:29.670993248 +0200
++++ src/comp/Makefile.am 2004-07-01 20:43:45.909524616 +0200
+@@ -18,7 +18,8 @@
+ gbc_output.c gbc_pcode.c \
+ gb_file.h gb_file.c \
+ gbc_form.h gbc_form.c \
+- gb_str.h gb_str.c
++ gb_str.h gb_str.c \
++ which.c
+
+ gba_SOURCES = \
+ gb_error.h gb_error.c \
+@@ -34,7 +35,8 @@
+ gb_alloc.c gb_array.c \
+ gb_str.h gb_str.c \
+ gb_file.h gb_file.c \
+- gbi.c
++ gbi.c \
++ which.c
+
+ %.h: ;
+
+--- src/comp/which.c.org 2003-10-27 21:51:41.000000000 +0100
++++ src/comp/which.c 2003-11-17 23:41:29.000000000 +0100
+@@ -0,0 +1,33 @@
++/* needed to install in a different location than /usr */
++
++#include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
++
++char *which(const char *app)
++{
++ char *path = NULL;
++ char *p = NULL;
++ char *rValue = NULL;
++
++ path = getenv("PATH");
++ if (!path) {
++ path = "/usr/bin/";
++ }
++ p = strtok(strdup(path), ":");
++ while (p) {
++ rValue = (char *)calloc(sizeof(char), strlen(p)+strlen(app)+2);
++ strcat(rValue, p);
++ rValue[strlen(p)] = '/';
++ strcat(rValue, app);
++ rValue[strlen(p)+1+strlen(app)] = '\0';
++ if (access(rValue, X_OK) == 0) {
++ return rValue;
++ }
++ p = strtok(NULL, ":");
++ free(rValue);
++ rValue = NULL;
++ }
++ return NULL;
++}
++
+--- src/comp/gbi.c.org 2003-10-27 21:51:41.000000000 +0100
++++ src/comp/gbi.c 2003-11-17 23:41:29.000000000 +0100
+@@ -54,6 +54,7 @@
+ #include "gb_str.h"
+ #include "gambas.h"
+
++char *which(const char *app);
+
+ PRIVATE char _lib_path[MAX_PATH + 1];
+ PRIVATE char _info_path[MAX_PATH + 1];
+@@ -102,7 +129,7 @@
+
+ /* chemin d'installation de Gambas */
+
+- path = FILE_readlink(GAMBAS_LINK_PATH);
++ path = which("gbx");
+ if (!path)
+ {
+ path = GAMBAS_LINK_PATH;
+@@ -422,7 +450,7 @@
+ if (strcmp(name, "gb") == 0)
+ {
+ sprintf(path, LIB_PATTERN, _lib_path, name);
+- dlib = dlopen("/usr/bin/gbx", RTLD_NOW);
++ dlib = dlopen(which("gbx"), RTLD_NOW);
+ if (!dlib)
+ error2("Cannot open component:", dlerror());
+
+@@ -472,7 +500,7 @@
+ sprintf(buf, "LD_PRELOAD=%s", lib);
+ putenv(buf);
+ putenv("GAMBAS_PRELOAD=1");
+- execv("/usr/bin/gbi", argv);
++ execvp("gbi", argv);
+ #endif
+ }
+
+--- src/comp/gbc_compile.c.org 2004-06-25 00:54:43.765214275 +0200
++++ src/comp/gbc_compile.c 2004-06-25 00:56:02.693198071 +0200
+@@ -59,6 +59,8 @@
+ PUBLIC COMPILE COMP_current;
+
+
++char *which(const char *app);
++
+ PRIVATE bool read_line(FILE *f, char *dir, int max)
+ {
+ char *p;
+@@ -126,7 +155,7 @@
+
+ /* chemin d'installation de Gambas */
+
+- path = FILE_readlink(GAMBAS_LINK_PATH);
++ path = which("gbx");
+ if (!path)
+ {
+ path = GAMBAS_LINK_PATH;