summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-11-02 18:21:21 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-11-02 18:21:21 +0000
commitabf1501abf35a63bd680622e4f054bcd22dabeaf (patch)
treec43a3275f1a434626052f73ef492bb33f6f0f57f /dev-util/elfkickers
parentBump (diff)
downloadgentoo-2-abf1501abf35a63bd680622e4f054bcd22dabeaf.tar.gz
gentoo-2-abf1501abf35a63bd680622e4f054bcd22dabeaf.tar.bz2
gentoo-2-abf1501abf35a63bd680622e4f054bcd22dabeaf.zip
Rev bump, bug #337108
(Portage version: 2.1.9.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/elfkickers')
-rw-r--r--dev-util/elfkickers/ChangeLog10
-rw-r--r--dev-util/elfkickers/elfkickers-2.0a-r5.ebuild56
-rw-r--r--dev-util/elfkickers/files/elfkickers-2.0a-bsd.patch16
-rw-r--r--dev-util/elfkickers/files/elfkickers-2.0a-elfls-core.patch10
-rw-r--r--dev-util/elfkickers/files/elfkickers-2.0a-make.patch14
-rw-r--r--dev-util/elfkickers/files/elfkickers-2.0a.diff105
-rw-r--r--dev-util/elfkickers/files/sstrip-mjn3.c483
-rw-r--r--dev-util/elfkickers/metadata.xml6
8 files changed, 70 insertions, 630 deletions
diff --git a/dev-util/elfkickers/ChangeLog b/dev-util/elfkickers/ChangeLog
index 45289a350cd3..1c3f3b95d37c 100644
--- a/dev-util/elfkickers/ChangeLog
+++ b/dev-util/elfkickers/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/elfkickers
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/ChangeLog,v 1.31 2010/03/05 22:06:33 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/ChangeLog,v 1.32 2010/11/02 18:21:20 blueness Exp $
+
+*elfkickers-2.0a-r5 (02 Nov 2010)
+
+ 02 Nov 2010; Anthony G. Basile <blueness@gentoo.org>
+ +elfkickers-2.0a-r5.ebuild, -files/elfkickers-2.0a.diff,
+ -files/elfkickers-2.0a-bsd.patch, -files/elfkickers-2.0a-elfls-core.patch,
+ -files/sstrip-mjn3.c, -files/elfkickers-2.0a-make.patch, metadata.xml:
+ Rev bump, bug #337108
05 Mar 2010; <solar@gentoo.org> -elfkickers-2.0a.ebuild,
-elfkickers-2.0a-r1.ebuild, -elfkickers-2.0a-r2.ebuild,
diff --git a/dev-util/elfkickers/elfkickers-2.0a-r5.ebuild b/dev-util/elfkickers/elfkickers-2.0a-r5.ebuild
new file mode 100644
index 000000000000..43af8d2cc86b
--- /dev/null
+++ b/dev-util/elfkickers/elfkickers-2.0a-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/elfkickers-2.0a-r5.ebuild,v 1.1 2010/11/02 18:21:20 blueness Exp $
+
+inherit eutils multilib toolchain-funcs
+
+MY_PN=${PN/elf/ELF}
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc"
+HOMEPAGE="http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
+SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}-${PV}.tar.gz
+ mirror://gentoo/elfkickers-2.0a-r5.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="app-misc/pax-utils"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/elfkickers-2.0a-r5.patch
+
+ sed -i -e '/^SUBDIRS/s:tiny::' Makefile
+ use x86 || sed -i -e '/^SUBDIRS/s:ebfc::' Makefile
+ use x86 && sed -i -e 's:linux/elf.h:elf.h:' ebfc/*.c
+ (cd tiny && make clean)
+}
+
+src_compile() {
+ for bits in 32 64; do
+ emake CC=$(tc-getCC) CFLAGS="-DELF_CLASS=ELFCLASS${bits} ${CFLAGS}" clean all
+ for x in elfls elftoc rebind sstrip; do
+ mv ${x}/$x{,${bits}} || die "moving failed of ${x}{,${bits}"
+ done
+ done
+}
+
+src_install() {
+ for d in elfls elftoc rebind sstrip ; do
+ newdoc ${d}/README README.${d} || die
+ dobin ${d}/${d}{32,64} || die
+ for i in ${d}/*.1; do
+ [ -e ${i} ] && doman ${i}
+ done
+ case $(get_libdir) in
+ lib64) dosym /usr/bin/${d}64 /usr/bin/${d};;
+ lib|lib32) dosym /usr/bin/${d}32 /usr/bin/${d};;
+ esac
+ done
+ dodoc Changelog README || die
+}
diff --git a/dev-util/elfkickers/files/elfkickers-2.0a-bsd.patch b/dev-util/elfkickers/files/elfkickers-2.0a-bsd.patch
deleted file mode 100644
index 7a840f0e4718..000000000000
--- a/dev-util/elfkickers/files/elfkickers-2.0a-bsd.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: ELFkickers/rebind/rebind.c
-===================================================================
---- ELFkickers.orig/rebind/rebind.c
-+++ ELFkickers/rebind/rebind.c
-@@ -7,7 +7,11 @@
- #include <string.h>
- #include <errno.h>
- #include <unistd.h>
-+#ifdef __linux__
- #include <linux/elf.h>
-+#else
-+#include <elf.h>
-+#endif
-
- #ifndef TRUE
- #define TRUE 1
diff --git a/dev-util/elfkickers/files/elfkickers-2.0a-elfls-core.patch b/dev-util/elfkickers/files/elfkickers-2.0a-elfls-core.patch
deleted file mode 100644
index 9b2f60a0747b..000000000000
--- a/dev-util/elfkickers/files/elfkickers-2.0a-elfls-core.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ELFkickers/elfls/elfls.c 2006-01-01 09:17:04.000000000 -0500
-+++ ELFkickers/elfls/elfls.c 2006-01-01 09:14:16.000000000 -0500
-@@ -317,6 +317,7 @@
- return FALSE;
- switch (elffhdr.e_type) {
- case ET_REL:
-+ case ET_CORE:
- case ET_EXEC:
- case ET_DYN:
- return TRUE;
diff --git a/dev-util/elfkickers/files/elfkickers-2.0a-make.patch b/dev-util/elfkickers/files/elfkickers-2.0a-make.patch
deleted file mode 100644
index 6447100613f9..000000000000
--- a/dev-util/elfkickers/files/elfkickers-2.0a-make.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: ELFkickers/Makefile
-===================================================================
---- ELFkickers.orig/Makefile
-+++ ELFkickers/Makefile
-@@ -1,7 +1,7 @@
- SUBDIRS = elfls elftoc rebind sstrip
-
- all:
-- for d in $(SUBDIRS); do cd $$d ; CFLAGS="$(CFLAGS)" CC=$(CC) make ; cd - ; done
-+ for d in $(SUBDIRS); do cd $$d ; CFLAGS="$(CFLAGS)" CC=$(CC) $(MAKE) ; cd - ; done
- clean:
-
-- for d in $(SUBDIRS); do cd $$d ; make clean; cd - ; done
-+ for d in $(SUBDIRS); do cd $$d ; $(MAKE) clean; cd - ; done
diff --git a/dev-util/elfkickers/files/elfkickers-2.0a.diff b/dev-util/elfkickers/files/elfkickers-2.0a.diff
deleted file mode 100644
index 7c43d0ec4203..000000000000
--- a/dev-util/elfkickers/files/elfkickers-2.0a.diff
+++ /dev/null
@@ -1,105 +0,0 @@
-diff -Nru ELFkickers.orig/Makefile ELFkickers/Makefile
---- ELFkickers.orig/Makefile 1969-12-31 19:00:00.000000000 -0500
-+++ ELFkickers/Makefile 2003-07-25 15:25:04.000000000 -0400
-@@ -0,0 +1,7 @@
-+SUBDIRS = ebfc elfls elftoc rebind sstrip tiny
-+
-+all:
-+ for d in $(SUBDIRS); do cd $$d ; CFLAGS="$(CFLAGS)" CC=$(CC) make ; cd - ; done
-+clean:
-+
-+ for d in $(SUBDIRS); do cd $$d ; make clean; cd - ; done
-diff -Nru ELFkickers.orig/ebfc/Makefile ELFkickers/ebfc/Makefile
---- ELFkickers.orig/ebfc/Makefile 2001-01-17 08:23:56.000000000 -0500
-+++ ELFkickers/ebfc/Makefile 2003-07-25 15:18:55.000000000 -0400
-@@ -1,8 +1,5 @@
- # Makefile for ebfc
-
--CC = gcc
--CFLAGS = -ggdb -Wall
--
- ebfc: ebfc.o brainfuck.o libelfparts.a
-
- ebfc.o: ebfc.c elfparts.h ebfc.h
-diff -Nru ELFkickers.orig/ebfc/rel.c ELFkickers/ebfc/rel.c
---- ELFkickers.orig/ebfc/rel.c 2001-03-19 10:50:18.000000000 -0500
-+++ ELFkickers/ebfc/rel.c 2003-07-25 15:16:08.000000000 -0400
-@@ -5,6 +5,7 @@
- */
-
- #include <stdlib.h>
-+#include <string.h>
- #include <linux/elf.h>
- #include "elfparts.h"
- #include "gen.h"
-diff -Nru ELFkickers.orig/elfls/Makefile ELFkickers/elfls/Makefile
---- ELFkickers.orig/elfls/Makefile 1999-07-07 23:57:55.000000000 -0400
-+++ ELFkickers/elfls/Makefile 2003-07-25 15:20:11.000000000 -0400
-@@ -1,7 +1,7 @@
- # Makefile for elfls
-
- elfls: elfls.c
-- gcc -ggdb -Wall -W -o elfls elfls.c
-+ $(CC) $(CFLAGS) -W -o elfls elfls.c
-
- clean:
- rm -f elfls
-diff -Nru ELFkickers.orig/elfls/elfls.c ELFkickers/elfls/elfls.c
---- ELFkickers.orig/elfls/elfls.c 2001-03-28 08:23:57.000000000 -0500
-+++ ELFkickers/elfls/elfls.c 2003-07-25 15:16:08.000000000 -0400
-@@ -4,6 +4,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <errno.h>
- #include <stdarg.h>
- #include <unistd.h>
-diff -Nru ELFkickers.orig/elftoc/Makefile ELFkickers/elftoc/Makefile
---- ELFkickers.orig/elftoc/Makefile 2001-03-26 05:48:59.000000000 -0500
-+++ ELFkickers/elftoc/Makefile 2003-07-25 15:21:00.000000000 -0400
-@@ -1,9 +1,5 @@
- # Makefile for elftoc
-
--CC = gcc
--CFLAGS = -ggdb -Wall
--LDFLAGS = $(CFLAGS)
--
- OBJS = pieces.o addr.o shdrtab.o dynamic.o outbasic.o outtools.o out.o elftoc.o
-
- elftoc: $(OBJS)
-diff -Nru ELFkickers.orig/elftoc/shdrtab.c ELFkickers/elftoc/shdrtab.c
---- ELFkickers.orig/elftoc/shdrtab.c 2001-03-25 08:09:09.000000000 -0500
-+++ ELFkickers/elftoc/shdrtab.c 2003-07-25 15:16:08.000000000 -0400
-@@ -5,6 +5,7 @@
- */
-
- #include <stdlib.h>
-+#include <string.h>
- #include <ctype.h>
- #include "gen.h"
- #include "elf.h"
-diff -Nru ELFkickers.orig/rebind/Makefile ELFkickers/rebind/Makefile
---- ELFkickers.orig/rebind/Makefile 2001-03-19 10:08:56.000000000 -0500
-+++ ELFkickers/rebind/Makefile 2003-07-25 15:21:26.000000000 -0400
-@@ -1,7 +1,7 @@
- # Makefile for rebind
-
- rebind: rebind.c
-- gcc -ggdb -Wall -W -o rebind rebind.c
-+ $(CC) $(CFLAGS) -W -o rebind rebind.c
-
- clean:
- rm -f rebind
-diff -Nru ELFkickers.orig/sstrip/Makefile ELFkickers/sstrip/Makefile
---- ELFkickers.orig/sstrip/Makefile 2001-03-24 06:58:27.000000000 -0500
-+++ ELFkickers/sstrip/Makefile 2003-07-25 15:21:47.000000000 -0400
-@@ -1,7 +1,7 @@
- # Makefile for sstrip
-
- sstrip: sstrip.c
-- gcc -ggdb -Wall -W -o sstrip sstrip.c
-+ $(CC) $(CFLAGS) -W -o sstrip sstrip.c
-
- clean:
- rm -f sstrip
diff --git a/dev-util/elfkickers/files/sstrip-mjn3.c b/dev-util/elfkickers/files/sstrip-mjn3.c
deleted file mode 100644
index e820a44b88bb..000000000000
--- a/dev-util/elfkickers/files/sstrip-mjn3.c
+++ /dev/null
@@ -1,483 +0,0 @@
-/* http://www.muppetlabs.com/~breadbox/software/elfkickers.html */
-
-/* sstrip: Copyright (C) 1999-2001 by Brian Raiter, under the GNU
- * General Public License. No warranty. See COPYING for details.
- *
- * Aug 23, 2004 Hacked by Manuel Novoa III <mjn3@codepoet.org> to
- * handle targets of different endianness and/or elf class, making
- * it more useful in a cross-devel environment.
- */
-
-/* ============== original README ===================
- *
- * sstrip is a small utility that removes the contents at the end of an
- * ELF file that are not part of the program's memory image.
- *
- * Most ELF executables are built with both a program header table and a
- * section header table. However, only the former is required in order
- * for the OS to load, link and execute a program. sstrip attempts to
- * extract the ELF header, the program header table, and its contents,
- * leaving everything else in the bit bucket. It can only remove parts of
- * the file that occur at the end, after the parts to be saved. However,
- * this almost always includes the section header table, and occasionally
- * a few random sections that are not used when running a program.
- *
- * It should be noted that the GNU bfd library is (understandably)
- * dependent on the section header table as an index to the file's
- * contents. Thus, an executable file that has no section header table
- * cannot be used with gdb, objdump, or any other program based upon the
- * bfd library, at all. In fact, the program will not even recognize the
- * file as a valid executable. (This limitation is noted in the source
- * code comments for bfd, and is marked "FIXME", so this may change at
- * some future date. However, I would imagine that it is a pretty
- * low-priority item, as executables without a section header table are
- * rare in the extreme.) This probably also explains why strip doesn't
- * offer the option to do this.
- *
- * Shared library files may also have their section header table removed.
- * Such a library will still function; however, it will no longer be
- * possible for a compiler to link a new program against it.
- *
- * As an added bonus, sstrip also tries to removes trailing zero bytes
- * from the end of the file. (This normally cannot be done with an
- * executable that has a section header table.)
- *
- * sstrip is a very simplistic program. It depends upon the common
- * practice of putting the parts of the file that contribute to the
- * memory image at the front, and the remaining material at the end. This
- * permits it to discard the latter material without affecting file
- * offsets and memory addresses in what remains. Of course, the ELF
- * standard permits files to be organized in almost any order, so if a
- * pathological linker decided to put its section headers at the top,
- * sstrip would be useless on such executables.
- */
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <errno.h>
-#include <unistd.h>
-#include <fcntl.h>
-#include <elf.h>
-#ifdef __FreeBSD__
-/**
- * This seems to work on FreeBSD 5.3, should
- * work on all newer versions as well. I have
- * no idea if it will work on versions < 5.3
- *
- * Joe Estock (guru) <jestock at nutextonline.com>
- */
-#include <sys/endian.h>
-#define bswap_64 __bswap64
-#define bswap_32 __bswap32
-#define bswap_16 __bswap16
-#else
-#include <endian.h>
-#include <byteswap.h>
-#endif /* defined(__FreeBSD__) */
-
-
-#ifndef TRUE
-#define TRUE 1
-#define FALSE 0
-#endif
-
-/* The name of the program.
- */
-static char const *progname;
-
-/* The name of the current file.
- */
-static char const *filename;
-
-
-/* A simple error-handling function. FALSE is always returned for the
- * convenience of the caller.
- */
-static int err(char const *errmsg)
-{
- fprintf(stderr, "%s: %s: %s\n", progname, filename, errmsg);
- return FALSE;
-}
-
-/* A flag to signal the need for endian reversal.
- */
-static int do_reverse_endian;
-
-/* Get a value from the elf header, compensating for endianness.
- */
-#define EGET(X) \
- (__extension__ ({ \
- uint64_t __res; \
- if (!do_reverse_endian) { \
- __res = (X); \
- } else if (sizeof(X) == 1) { \
- __res = (X); \
- } else if (sizeof(X) == 2) { \
- __res = bswap_16((X)); \
- } else if (sizeof(X) == 4) { \
- __res = bswap_32((X)); \
- } else if (sizeof(X) == 8) { \
- __res = bswap_64((X)); \
- } else { \
- fprintf(stderr, "%s: %s: EGET failed for size %d\n", \
- progname, filename, sizeof(X)); \
- exit(EXIT_FAILURE); \
- } \
- __res; \
- }))
-
-/* Set a value 'Y' in the elf header to 'X', compensating for endianness.
- */
-#define ESET(Y,X) \
- do if (!do_reverse_endian) { \
- Y = (X); \
- } else if (sizeof(Y) == 1) { \
- Y = (X); \
- } else if (sizeof(Y) == 2) { \
- Y = bswap_16((uint16_t)(X)); \
- } else if (sizeof(Y) == 4) { \
- Y = bswap_32((uint32_t)(X)); \
- } else if (sizeof(Y) == 8) { \
- Y = bswap_64((uint64_t)(X)); \
- } else { \
- fprintf(stderr, "%s: %s: ESET failed for size %d\n", \
- progname, filename, sizeof(Y)); \
- exit(EXIT_FAILURE); \
- } while (0)
-
-
-/* A macro for I/O errors: The given error message is used only when
- * errno is not set.
- */
-#define ferr(msg) (err(errno ? strerror(errno) : (msg)))
-
-
-
-#define HEADER_FUNCTIONS(CLASS) \
- \
-/* readelfheader() reads the ELF header into our global variable, and \
- * checks to make sure that this is in fact a file that we should be \
- * munging. \
- */ \
-static int readelfheader ## CLASS (int fd, Elf ## CLASS ## _Ehdr *ehdr) \
-{ \
- if (read(fd, ((char *)ehdr)+EI_NIDENT, sizeof(*ehdr) - EI_NIDENT) \
- != sizeof(*ehdr) - EI_NIDENT) \
- return ferr("missing or incomplete ELF header."); \
- \
- /* Verify the sizes of the ELF header and the program segment \
- * header table entries. \
- */ \
- if (EGET(ehdr->e_ehsize) != sizeof(Elf ## CLASS ## _Ehdr)) \
- return err("unrecognized ELF header size."); \
- if (EGET(ehdr->e_phentsize) != sizeof(Elf ## CLASS ## _Phdr)) \
- return err("unrecognized program segment header size."); \
- \
- /* Finally, check the file type. \
- */ \
- if (EGET(ehdr->e_type) != ET_EXEC && EGET(ehdr->e_type) != ET_DYN) \
- return err("not an executable or shared-object library."); \
- \
- return TRUE; \
-} \
- \
-/* readphdrtable() loads the program segment header table into memory. \
- */ \
-static int readphdrtable ## CLASS (int fd, Elf ## CLASS ## _Ehdr const *ehdr, \
- Elf ## CLASS ## _Phdr **phdrs) \
-{ \
- size_t size; \
- \
- if (!EGET(ehdr->e_phoff) || !EGET(ehdr->e_phnum) \
-) return err("ELF file has no program header table."); \
- \
- size = EGET(ehdr->e_phnum) * sizeof **phdrs; \
- if (!(*phdrs = malloc(size))) \
- return err("Out of memory!"); \
- \
- errno = 0; \
- if (read(fd, *phdrs, size) != (ssize_t)size) \
- return ferr("missing or incomplete program segment header table."); \
- \
- return TRUE; \
-} \
- \
-/* getmemorysize() determines the offset of the last byte of the file \
- * that is referenced by an entry in the program segment header table. \
- * (Anything in the file after that point is not used when the program \
- * is executing, and thus can be safely discarded.) \
- */ \
-static int getmemorysize ## CLASS (Elf ## CLASS ## _Ehdr const *ehdr, \
- Elf ## CLASS ## _Phdr const *phdrs, \
- unsigned long *newsize) \
-{ \
- Elf ## CLASS ## _Phdr const *phdr; \
- unsigned long size, n; \
- int i; \
- \
- /* Start by setting the size to include the ELF header and the \
- * complete program segment header table. \
- */ \
- size = EGET(ehdr->e_phoff) + EGET(ehdr->e_phnum) * sizeof *phdrs; \
- if (size < sizeof *ehdr) \
- size = sizeof *ehdr; \
- \
- /* Then keep extending the size to include whatever data the \
- * program segment header table references. \
- */ \
- for (i = 0, phdr = phdrs ; i < EGET(ehdr->e_phnum) ; ++i, ++phdr) { \
- if (EGET(phdr->p_type) != PT_NULL) { \
- n = EGET(phdr->p_offset) + EGET(phdr->p_filesz); \
- if (n > size) \
- size = n; \
- } \
- } \
- \
- *newsize = size; \
- return TRUE; \
-} \
- \
-/* modifyheaders() removes references to the section header table if \
- * it was stripped, and reduces program header table entries that \
- * included truncated bytes at the end of the file. \
- */ \
-static int modifyheaders ## CLASS (Elf ## CLASS ## _Ehdr *ehdr, \
- Elf ## CLASS ## _Phdr *phdrs, \
- unsigned long newsize) \
-{ \
- Elf ## CLASS ## _Phdr *phdr; \
- int i; \
- \
- /* If the section header table is gone, then remove all references \
- * to it in the ELF header. \
- */ \
- if (EGET(ehdr->e_shoff) >= newsize) { \
- ESET(ehdr->e_shoff,0); \
- ESET(ehdr->e_shnum,0); \
- ESET(ehdr->e_shentsize,0); \
- ESET(ehdr->e_shstrndx,0); \
- } \
- \
- /* The program adjusts the file size of any segment that was \
- * truncated. The case of a segment being completely stripped out \
- * is handled separately. \
- */ \
- for (i = 0, phdr = phdrs ; i < EGET(ehdr->e_phnum) ; ++i, ++phdr) { \
- if (EGET(phdr->p_offset) >= newsize) { \
- ESET(phdr->p_offset,newsize); \
- ESET(phdr->p_filesz,0); \
- } else if (EGET(phdr->p_offset) + EGET(phdr->p_filesz) > newsize) { \
- newsize -= EGET(phdr->p_offset); \
- ESET(phdr->p_filesz, newsize); \
- } \
- } \
- \
- return TRUE; \
-} \
- \
-/* commitchanges() writes the new headers back to the original file \
- * and sets the file to its new size. \
- */ \
-static int commitchanges ## CLASS (int fd, Elf ## CLASS ## _Ehdr const *ehdr, \
- Elf ## CLASS ## _Phdr *phdrs, \
- unsigned long newsize) \
-{ \
- size_t n; \
- \
- /* Save the changes to the ELF header, if any. \
- */ \
- if (lseek(fd, 0, SEEK_SET)) \
- return ferr("could not rewind file"); \
- errno = 0; \
- if (write(fd, ehdr, sizeof *ehdr) != sizeof *ehdr) \
- return err("could not modify file"); \
- \
- /* Save the changes to the program segment header table, if any. \
- */ \
- if (lseek(fd, EGET(ehdr->e_phoff), SEEK_SET) == (off_t)-1) { \
- err("could not seek in file."); \
- goto warning; \
- } \
- n = EGET(ehdr->e_phnum) * sizeof *phdrs; \
- if (write(fd, phdrs, n) != (ssize_t)n) { \
- err("could not write to file"); \
- goto warning; \
- } \
- \
- /* Eleventh-hour sanity check: don't truncate before the end of \
- * the program segment header table. \
- */ \
- if (newsize < EGET(ehdr->e_phoff) + n) \
- newsize = EGET(ehdr->e_phoff) + n; \
- \
- /* Chop off the end of the file. \
- */ \
- if (ftruncate(fd, newsize)) { \
- err("could not resize file"); \
- goto warning; \
- } \
- \
- return TRUE; \
- \
- warning: \
- return err("ELF file may have been corrupted!"); \
-}
-
-
-/* First elements of Elf32_Ehdr and Elf64_Ehdr are common.
- */
-static int readelfheaderident(int fd, Elf32_Ehdr *ehdr)
-{
- errno = 0;
- if (read(fd, ehdr, EI_NIDENT) != EI_NIDENT)
- return ferr("missing or incomplete ELF header.");
-
- /* Check the ELF signature.
- */
- if (!(ehdr->e_ident[EI_MAG0] == ELFMAG0 &&
- ehdr->e_ident[EI_MAG1] == ELFMAG1 &&
- ehdr->e_ident[EI_MAG2] == ELFMAG2 &&
- ehdr->e_ident[EI_MAG3] == ELFMAG3))
- {
- err("missing ELF signature.");
- return -1;
- }
-
- /* Compare the file's class and endianness with the program's.
- */
-#if __BYTE_ORDER == __LITTLE_ENDIAN
- if (ehdr->e_ident[EI_DATA] == ELFDATA2LSB) {
- do_reverse_endian = 0;
- } else if (ehdr->e_ident[EI_DATA] == ELFDATA2MSB) {
-/* fprintf(stderr, "ELF file has different endianness.\n"); */
- do_reverse_endian = 1;
- }
-#elif __BYTE_ORDER == __BIG_ENDIAN
- if (ehdr->e_ident[EI_DATA] == ELFDATA2LSB) {
-/* fprintf(stderr, "ELF file has different endianness.\n"); */
- do_reverse_endian = 1;
- } else if (ehdr->e_ident[EI_DATA] == ELFDATA2MSB) {
- do_reverse_endian = 0;
- }
-#else
-#error unkown endianness
-#endif
- else {
- err("Unsupported endianness");
- return -1;
- }
-
- /* Check the target architecture.
- */
-/* if (EGET(ehdr->e_machine) != ELF_ARCH) { */
-/* /\* return err("ELF file created for different architecture."); *\/ */
-/* fprintf(stderr, "ELF file created for different architecture.\n"); */
-/* } */
- return ehdr->e_ident[EI_CLASS];
-}
-
-
-HEADER_FUNCTIONS(32)
-
-HEADER_FUNCTIONS(64)
-
-/* truncatezeros() examines the bytes at the end of the file's
- * size-to-be, and reduces the size to exclude any trailing zero
- * bytes.
- */
-static int truncatezeros(int fd, unsigned long *newsize)
-{
- unsigned char contents[1024];
- unsigned long size, n;
-
- size = *newsize;
- do {
- n = sizeof contents;
- if (n > size)
- n = size;
- if (lseek(fd, size - n, SEEK_SET) == (off_t)-1)
- return ferr("cannot seek in file.");
- if (read(fd, contents, n) != (ssize_t)n)
- return ferr("cannot read file contents");
- while (n && !contents[--n])
- --size;
- } while (size && !n);
-
- /* Sanity check.
- */
- if (!size)
- return err("ELF file is completely blank!");
-
- *newsize = size;
- return TRUE;
-}
-
-/* main() loops over the cmdline arguments, leaving all the real work
- * to the other functions.
- */
-int main(int argc, char *argv[])
-{
- int fd;
- union {
- Elf32_Ehdr ehdr32;
- Elf64_Ehdr ehdr64;
- } e;
- union {
- Elf32_Phdr *phdrs32;
- Elf64_Phdr *phdrs64;
- } p;
- unsigned long newsize;
- char **arg;
- int failures = 0;
-
- if (argc < 2 || argv[1][0] == '-') {
- printf("Usage: sstrip FILE...\n"
- "sstrip discards all nonessential bytes from an executable.\n\n"
- "Version 2.0-X Copyright (C) 2000,2001 Brian Raiter.\n"
- "Cross-devel hacks Copyright (C) 2004 Manuel Novoa III.\n"
- "This program is free software, licensed under the GNU\n"
- "General Public License. There is absolutely no warranty.\n");
- return EXIT_SUCCESS;
- }
-
- progname = argv[0];
-
- for (arg = argv + 1 ; *arg != NULL ; ++arg) {
- filename = *arg;
-
- fd = open(*arg, O_RDWR);
- if (fd < 0) {
- ferr("can't open");
- ++failures;
- continue;
- }
-
- switch (readelfheaderident(fd, &e.ehdr32)) {
- case ELFCLASS32:
- if (!(readelfheader32(fd, &e.ehdr32) &&
- readphdrtable32(fd, &e.ehdr32, &p.phdrs32) &&
- getmemorysize32(&e.ehdr32, p.phdrs32, &newsize) &&
- truncatezeros(fd, &newsize) &&
- modifyheaders32(&e.ehdr32, p.phdrs32, newsize) &&
- commitchanges32(fd, &e.ehdr32, p.phdrs32, newsize)))
- ++failures;
- break;
- case ELFCLASS64:
- if (!(readelfheader64(fd, &e.ehdr64) &&
- readphdrtable64(fd, &e.ehdr64, &p.phdrs64) &&
- getmemorysize64(&e.ehdr64, p.phdrs64, &newsize) &&
- truncatezeros(fd, &newsize) &&
- modifyheaders64(&e.ehdr64, p.phdrs64, newsize) &&
- commitchanges64(fd, &e.ehdr64, p.phdrs64, newsize)))
- ++failures;
- break;
- default:
- ++failures;
- break;
- }
- close(fd);
- }
-
- return failures ? EXIT_FAILURE : EXIT_SUCCESS;
-}
diff --git a/dev-util/elfkickers/metadata.xml b/dev-util/elfkickers/metadata.xml
index 2f76d1ab72f6..b605da0c93d1 100644
--- a/dev-util/elfkickers/metadata.xml
+++ b/dev-util/elfkickers/metadata.xml
@@ -3,8 +3,12 @@
<pkgmetadata>
<herd>hardened</herd>
<maintainer>
- <email>solar@gentoo.org</email>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
<description>Primary Maintainer</description>
</maintainer>
+ <maintainer>
+ <email>solar@gentoo.org</email>
+ </maintainer>
<longdescription>ELF kickers is a collection of programs that manipulate ELF files. The main purpose of these programs is to be illustrative and educational -- to help fellow programmers understand the ELF file format and something of how it works under the Linux platform.</longdescription>
</pkgmetadata>