summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-05-13 23:59:25 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-05-13 23:59:25 +0000
commit19ff1864d5f9dfc59c10e84abfc49dffb094545b (patch)
tree7f8912d0c52f014c90144188fef0c49cd33a89dd /dev-util/dmake
parentVersion bump for gnome-3.4 with numerous changes. (diff)
downloadgentoo-2-19ff1864d5f9dfc59c10e84abfc49dffb094545b.tar.gz
gentoo-2-19ff1864d5f9dfc59c10e84abfc49dffb094545b.tar.bz2
gentoo-2-19ff1864d5f9dfc59c10e84abfc49dffb094545b.zip
Fix tests, bug #404989. Version bump, drop merged patch.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/dmake')
-rw-r--r--dev-util/dmake/ChangeLog8
-rw-r--r--dev-util/dmake/dmake-4.12.2.ebuild36
-rw-r--r--dev-util/dmake/dmake-4.12.ebuild7
3 files changed, 46 insertions, 5 deletions
diff --git a/dev-util/dmake/ChangeLog b/dev-util/dmake/ChangeLog
index 7d12a6fd11a8..cba22b95fd02 100644
--- a/dev-util/dmake/ChangeLog
+++ b/dev-util/dmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/dmake
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/ChangeLog,v 1.26 2012/05/13 20:32:08 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/ChangeLog,v 1.27 2012/05/13 23:59:25 chithanh Exp $
+
+*dmake-4.12.2 (13 May 2012)
+
+ 13 May 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +dmake-4.12.2.ebuild, dmake-4.12.ebuild:
+ Fix tests, bug #404989. Version bump, drop merged patch.
13 May 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
dmake-4.12.ebuild:
diff --git a/dev-util/dmake/dmake-4.12.2.ebuild b/dev-util/dmake/dmake-4.12.2.ebuild
new file mode 100644
index 000000000000..54476feacd1b
--- /dev/null
+++ b/dev-util/dmake/dmake-4.12.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/dmake-4.12.2.ebuild,v 1.1 2012/05/13 23:59:25 chithanh Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Improved make"
+HOMEPAGE="http://code.google.com/a/apache-extras.org/p/dmake/"
+SRC_URI="http://${PN}.apache-extras.org.codespot.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+# test failure, reported upstream at
+# http://code.google.com/a/apache-extras.org/p/dmake/issues/detail?id=1
+RESTRICT="test"
+
+DEPEND="
+ app-arch/unzip
+ sys-apps/groff
+"
+RDEPEND=""
+
+src_prepare() {
+ # make tests executable, bug #404989
+ chmod +x tests/targets-{1..12} || die
+}
+
+src_install () {
+ default
+ newman man/dmake.tf dmake.1
+}
diff --git a/dev-util/dmake/dmake-4.12.ebuild b/dev-util/dmake/dmake-4.12.ebuild
index 079029db4706..85456e8b2ca9 100644
--- a/dev-util/dmake/dmake-4.12.ebuild
+++ b/dev-util/dmake/dmake-4.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/dmake-4.12.ebuild,v 1.2 2012/05/13 20:32:07 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/dmake-4.12.ebuild,v 1.3 2012/05/13 23:59:25 chithanh Exp $
EAPI=4
@@ -15,9 +15,6 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-# tests fail, bug #404989
-RESTRICT="test"
-
DEPEND="
app-arch/unzip
sys-apps/groff
@@ -26,6 +23,8 @@ RDEPEND=""
src_prepare() {
epatch "${FILESDIR}/${PV}-fix-overlapping-stcpys.patch"
+ # make tests executable, bug #404989
+ chmod +x tests/targets-{1..12} || die
}
src_install () {