summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-02-15 15:41:45 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-02-15 15:41:45 +0000
commit90778061f0ca8878a9a60c1890f3fe8a9d7410c0 (patch)
treef0b611fa82744316596fc24e70480a1783f5b8d4 /dev-util/darcs/darcs-1.0.2.ebuild
parentInstall icons in the correct place and provide a desktop entry for bug 81055.... (diff)
downloadgentoo-2-90778061f0ca8878a9a60c1890f3fe8a9d7410c0.tar.gz
gentoo-2-90778061f0ca8878a9a60c1890f3fe8a9d7410c0.tar.bz2
gentoo-2-90778061f0ca8878a9a60c1890f3fe8a9d7410c0.zip
new version
Diffstat (limited to 'dev-util/darcs/darcs-1.0.2.ebuild')
-rw-r--r--dev-util/darcs/darcs-1.0.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/darcs/darcs-1.0.2.ebuild b/dev-util/darcs/darcs-1.0.2.ebuild
new file mode 100644
index 000000000000..012c03285323
--- /dev/null
+++ b/dev-util/darcs/darcs-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.2.ebuild,v 1.1 2005/02/15 15:41:45 kosmikus Exp $
+
+DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
+HOMEPAGE="http://abridgegame.org/darcs"
+SRC_URI="http://abridgegame.org/darcs/${P/_rc/rc}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+# disabled wxwindows use flag for now, as I got build errors
+
+DEPEND=">=net-misc/curl-7.10.2
+ >=virtual/ghc-6.2
+ doc? ( virtual/tetex
+ dev-tex/latex2html )"
+# wxwindows? ( dev-haskell/wxhaskell )
+
+RDEPEND=">=net-misc/curl-7.10.2"
+# wxwindows? ( dev-haskell/wxhaskell )"
+
+S=${WORKDIR}/${P/_rc/rc}
+
+src_compile() {
+ local myconf
+# myconf="`use_with wxwindows wx`"
+ # distribution contains garbage files
+ make clean || die "make clean failed"
+ if use doc ; then
+ sed -i "s:/doc:/doc/${PF}:" GNUmakefile
+ else
+ sed -i \
+ -e 's: installdocs::' \
+ -e 's:^.*BUILDDOC.*yes.*$::' \
+ -e 's/^.*TARGETS.*\(darcs\.ps\|manual\).*$/:/' \
+ configure
+ fi
+ econf ${myconf} || die "configure failed"
+ echo 'INSTALLWHAT=installbin' >> autoconf.mk
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "installation failed"
+}