summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-15 17:26:18 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-15 17:26:18 +0000
commita565a71c718ab3f391a0a25d2977b3d5e25182f3 (patch)
treeea21e3be68d2807e7305b3bcdeefae43218ea60e /dev-util/cvsweb/cvsweb-1.112.ebuild
parentMoved from net-www/mod_tcl to www-apache/mod_tcl (diff)
downloadgentoo-2-a565a71c718ab3f391a0a25d2977b3d5e25182f3.tar.gz
gentoo-2-a565a71c718ab3f391a0a25d2977b3d5e25182f3.tar.bz2
gentoo-2-a565a71c718ab3f391a0a25d2977b3d5e25182f3.zip
Moved from net-www/cvsweb to dev-util/cvsweb.
Diffstat (limited to 'dev-util/cvsweb/cvsweb-1.112.ebuild')
-rw-r--r--dev-util/cvsweb/cvsweb-1.112.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/cvsweb/cvsweb-1.112.ebuild b/dev-util/cvsweb/cvsweb-1.112.ebuild
new file mode 100644
index 000000000000..c5ce9c29d9ae
--- /dev/null
+++ b/dev-util/cvsweb/cvsweb-1.112.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-1.112.ebuild,v 1.1 2004/08/15 17:26:18 stuart Exp $
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://stud.fh-heilbronn.de/~zeller/cgi/cvsweb.cgi"
+SRC_URI="http://stud.fh-heilbronn.de/~zeller/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5
+ >=app-text/rcs-5.7"
+
+S="${WORKDIR}/cvsweb"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ local x
+ for x in cvsweb.cgi cvsweb.conf
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:/usr/local/web/apache/conf/:/etc/apache/conf/:g" ${x}.orig > ${x}
+ done
+}
+
+src_install() {
+ cd ${S}
+ insinto /etc/apache/conf
+ doins cvsweb.conf
+ insinto /home/httpd/cgi-bin
+ insopts -m755
+ doins cvsweb.cgi
+ dodoc README TODO
+}