summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-15 11:56:09 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-15 11:56:09 +0000
commit773d1be3d7c8f78de6c9e34df2b74f6f960f0de6 (patch)
tree721da84f337aa3a6772f119807aec3ecae090a7c /dev-util/cvsgraph/cvsgraph-1.5.2.ebuild
parentSecurity removal, see bug 74703 (diff)
downloadgentoo-2-773d1be3d7c8f78de6c9e34df2b74f6f960f0de6.tar.gz
gentoo-2-773d1be3d7c8f78de6c9e34df2b74f6f960f0de6.tar.bz2
gentoo-2-773d1be3d7c8f78de6c9e34df2b74f6f960f0de6.zip
Version bump; tidy old ebuilds.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/cvsgraph/cvsgraph-1.5.2.ebuild')
-rw-r--r--dev-util/cvsgraph/cvsgraph-1.5.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cvsgraph/cvsgraph-1.5.2.ebuild b/dev-util/cvsgraph/cvsgraph-1.5.2.ebuild
new file mode 100644
index 000000000000..1aec37d90d2f
--- /dev/null
+++ b/dev-util/cvsgraph/cvsgraph-1.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsgraph/cvsgraph-1.5.2.ebuild,v 1.1 2005/06/15 11:56:09 ka0ttic Exp $
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc -alpha -amd64 -ia64"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( media-libs/freetype )"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README contrib/*.php3
+}