summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-01-01 15:12:42 +0000
committerMichael Weber <xmw@gentoo.org>2011-01-01 15:12:42 +0000
commitae77c29b5399529c094dc317ab7279a84af2836e (patch)
treeb4f8989dcbd0c488708c1c68e40962e9c7d0f034 /dev-util/cppcheck
parentadd ~sparc keyword (bug 350200) (diff)
downloadgentoo-2-ae77c29b5399529c094dc317ab7279a84af2836e.tar.gz
gentoo-2-ae77c29b5399529c094dc317ab7279a84af2836e.tar.bz2
gentoo-2-ae77c29b5399529c094dc317ab7279a84af2836e.zip
Version bump (bug 349284)
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog10
-rw-r--r--dev-util/cppcheck/cppcheck-1.46.1.ebuild75
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index eb92af62e233..4e56c07968f0 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppcheck
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.19 2010/11/11 12:07:38 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.20 2011/01/01 15:12:42 xmw Exp $
+
+*cppcheck-1.46.1 (01 Jan 2011)
+
+ 01 Jan 2011; Michael Weber <xmw@gentoo.org> +cppcheck-1.46.1.ebuild:
+ Version bump (thanks to Andrey Hippo <ahippo@yandex.ru> for the report on bug
+ 349284)
*cppcheck-1.45-r1 (11 Nov 2010)
diff --git a/dev-util/cppcheck/cppcheck-1.46.1.ebuild b/dev-util/cppcheck/cppcheck-1.46.1.ebuild
new file mode 100644
index 000000000000..f12e4ebaf70a
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.46.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.46.1.ebuild,v 1.1 2011/01/01 15:12:42 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils python toolchain-funcs qt4-r2
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-assistant:4 )"
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils_src_install
+ popd
+ fi
+}