summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-04 08:07:40 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-04 08:07:40 +0000
commitae72c74bf08fe747aa5c49ffda3525ef8d22d078 (patch)
treec8270041e3a939afe47971b0c03f33246d353b67 /dev-util/coccinelle/files
parentRemove old version (diff)
downloadgentoo-2-ae72c74bf08fe747aa5c49ffda3525ef8d22d078.tar.gz
gentoo-2-ae72c74bf08fe747aa5c49ffda3525ef8d22d078.tar.bz2
gentoo-2-ae72c74bf08fe747aa5c49ffda3525ef8d22d078.zip
Version bump (fixes bug #369343). Update to EAPI 4 and improve python support (bug #324381).
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/coccinelle/files')
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.0.0_rc7-parallel-make.patch8
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch19
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch30
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-parallel-make.patch b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-parallel-make.patch
new file mode 100644
index 000000000000..a95eba1711aa
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-parallel-make.patch
@@ -0,0 +1,8 @@
+--- coccinelle-1.0.0-rc7/docs/Makefile.orig
++++ coccinelle-1.0.0-rc7/docs/Makefile
+@@ -13,4 +13,4 @@
+ rm -f spatch.1
+
+ all clean distclean::
+- make -C $(SUBDIR) $@
++ $(MAKE) -C $(SUBDIR) $@
diff --git a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch
new file mode 100644
index 000000000000..271dcf9ceedc
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch
@@ -0,0 +1,19 @@
+--- coccinelle-1.0.0-rc7/Makefile.orig
++++ coccinelle-1.0.0-rc7/Makefile
+@@ -225,13 +225,13 @@
+ $(OPTOBJS):$(LIBS:.cma=.cmxa)
+
+ $(EXEC): $(LIBS) $(OBJS)
+- $(OCAMLC) $(BYTECODE_STATIC) -o $@ $(SYSLIBS) $(SEXPLIB) $^
++ $(OCAMLC) $(BYTECODE_STATIC) -o $@ $(SYSLIBS) $(SEXPLIB) $^ $(PCRELIB)
+
+ $(EXEC).opt: $(LIBS:.cma=.cmxa) $(OPTOBJS)
+- $(OCAMLOPT) $(STATIC) -o $@ $(SYSLIBS:.cma=.cmxa) $(OPTSEXPLIB) $(OPTLIBFLAGS) $^
++ $(OCAMLOPT) $(STATIC) -o $@ $(SYSLIBS:.cma=.cmxa) $(OPTSEXPLIB) $(OPTLIBFLAGS) $^ $(PCRELIB:.cma=.cmxa)
+
+ $(EXEC).top: $(LIBS) $(OBJS)
+- $(OCAMLMKTOP) -custom -o $@ $(SYSLIBS) $(SEXPLIB) $^
++ $(OCAMLMKTOP) -custom -o $@ $(SYSLIBS) $(SEXPLIB) $^ $(PCRELIB)
+
+ clean::
+ rm -f $(TARGET) $(TARGET).opt $(TARGET).top
diff --git a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch
new file mode 100644
index 000000000000..d9b5c9e3f427
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch
@@ -0,0 +1,30 @@
+http://www.mail-archive.com/cocci@diku.dk/msg01695.html
+
+diff --git a/parsing_cocci/function_prototypes.ml b/parsing_cocci/function_prototypes.ml
+index 2f2225a..257e0ca 100644
+--- a/parsing_cocci/function_prototypes.ml
++++ b/parsing_cocci/function_prototypes.ml
+@@ -153,18 +153,19 @@ and strip =
+ ref [],-1) in
+
+ (* need a case for everything that has an unvisited component and can be in
+- a function prototype *)
++ a function prototype. Also get rid of constraints because pcre
++ constraints cannot be compared. *)
+
+ let ident r k e =
+ donothing r k
+ (Ast0.rewrap e
+ (match Ast0.unwrap e with
+ Ast0.MetaId(nm,constraints,seed,pure) ->
+- Ast0.MetaId(nm,constraints,seed,Ast0.Pure)
++ Ast0.MetaId(nm,Ast.IdNoConstraint,seed,Ast0.Pure)
+ | Ast0.MetaFunc(nm,constraints,pure) ->
+- Ast0.MetaFunc(nm,constraints,Ast0.Pure)
++ Ast0.MetaFunc(nm,Ast.IdNoConstraint,Ast0.Pure)
+ | Ast0.MetaLocalFunc(nm,constraints,pure) ->
+- Ast0.MetaLocalFunc(nm,constraints,Ast0.Pure)
++ Ast0.MetaLocalFunc(nm,Ast.IdNoConstraint,Ast0.Pure)
+ | e -> e)) in
+
+ let typeC r k e =