summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-09-15 22:43:29 +0000
committerJohannes Huber <johu@gentoo.org>2014-09-15 22:43:29 +0000
commit990ff2fe237424610187b7f11247063dcb4591cd (patch)
tree86b21e3e87b559393ae4cc74f4ea0cc8bf8db0b6 /dev-util/cmake
parentMask zrtpcpp-4 since it is screwed up. (diff)
downloadgentoo-2-990ff2fe237424610187b7f11247063dcb4591cd.tar.gz
gentoo-2-990ff2fe237424610187b7f11247063dcb4591cd.tar.bz2
gentoo-2-990ff2fe237424610187b7f11247063dcb4591cd.zip
Version bump, adds updated patch for FindLAPACK module by Eugene Shalygin <eugene.shalygin@gmail.com>, bug #518910. Remove old.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog10
-rw-r--r--dev-util/cmake/cmake-3.0.2.ebuild (renamed from dev-util/cmake/cmake-3.0.0.ebuild)4
-rw-r--r--dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch (renamed from dev-util/cmake/files/cmake-3.0.0-FindLAPACK.patch)21
3 files changed, 21 insertions, 14 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index f330a04e9f9b..2ebd12d80efd 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.297 2014/08/21 19:42:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.298 2014/09/15 22:43:29 johu Exp $
+
+*cmake-3.0.2 (15 Sep 2014)
+
+ 15 Sep 2014; Johannes Huber <johu@gentoo.org> +cmake-3.0.2.ebuild,
+ +files/cmake-3.0.2-FindLAPACK.patch, -cmake-3.0.0.ebuild,
+ -files/cmake-3.0.0-FindLAPACK.patch:
+ Version bump, adds updated patch for FindLAPACK module by Eugene Shalygin
+ <eugene.shalygin@gmail.com>, bug #518910. Remove old.
*cmake-2.8.12.2-r2 (21 Aug 2014)
diff --git a/dev-util/cmake/cmake-3.0.0.ebuild b/dev-util/cmake/cmake-3.0.2.ebuild
index 6d62ab3e677f..182564dfbcaf 100644
--- a/dev-util/cmake/cmake-3.0.0.ebuild
+++ b/dev-util/cmake/cmake-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.0.0.ebuild,v 1.1 2014/07/27 11:55:54 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.0.2.ebuild,v 1.1 2014/09/15 22:43:29 johu Exp $
EAPI=5
@@ -52,9 +52,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.10.2-FindPythonLibs.patch
"${FILESDIR}"/${PN}-2.8.12.1-FindImageMagick.patch
"${FILESDIR}"/${PN}-3.0.0-FindBLAS.patch
- "${FILESDIR}"/${PN}-3.0.0-FindLAPACK.patch
"${FILESDIR}"/${PN}-3.0.0-FindBoost-python.patch
"${FILESDIR}"/${PN}-3.0.0-prefix-dirs.patch
+ "${FILESDIR}"/${PN}-3.0.2-FindLAPACK.patch
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-3.0.0-FindLAPACK.patch b/dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch
index 611c5ceb94f7..57250e453be0 100644
--- a/dev-util/cmake/files/cmake-3.0.0-FindLAPACK.patch
+++ b/dev-util/cmake/files/cmake-3.0.2-FindLAPACK.patch
@@ -1,5 +1,5 @@
---- Modules/FindLAPACK.cmake
-+++ Modules/FindLAPACK.cmake
+--- Modules/FindLAPACK.cmake.orig 2014-09-15 23:50:11.377111987 +0200
++++ Modules/FindLAPACK.cmake 2014-09-15 23:52:54.734388375 +0200
@@ -4,6 +4,10 @@
#
# Find LAPACK library
@@ -11,9 +11,9 @@
# This module finds an installed fortran library that implements the
# LAPACK linear-algebra interface (see http://www.netlib.org/lapack/).
#
-@@ -72,6 +76,24 @@
- # N.B. _prefix is the prefix applied to the names of all cached variables that
- # are generated internally and marked advanced by this macro.
+@@ -140,6 +144,23 @@
+
+ endmacro()
+#
+# first, try PkgConfig
@@ -26,17 +26,16 @@
+ if (NOT ${PC_LIB}_LIBRARY)
+ message(FATAL_ERROR "Something is wrong in your pkg-config file - lib ${PC_LIB} not found in ${PC_LAPACK_LIBRARY_DIRS}")
+ endif (NOT ${PC_LIB}_LIBRARY)
-+ list(APPEND LAPACK_LIBRARIES ${${PC_LIB}_LIBRARY})
++ list(APPEND LAPACK_LIBRARIES ${${PC_LIB}_LIBRARY})
+ endforeach(PC_LIB)
+ find_package_handle_standard_args(LAPACK DEFAULT_MSG LAPACK_LIBRARIES)
+ mark_as_advanced(LAPACK_LIBRARIES)
+else(PC_LAPACK_FOUND)
+message(STATUS "No PkgConfig configuration for LAPACK found; starting more extensive search.")
-+
- set(_libraries_work TRUE)
- set(${LIBRARIES})
- set(_combined_name)
-@@ -348,3 +370,5 @@
+
+ set(LAPACK_LINKER_FLAGS)
+ set(LAPACK_LIBRARIES)
+@@ -348,3 +369,5 @@
endif()
set(CMAKE_FIND_LIBRARY_SUFFIXES ${_lapack_ORIG_CMAKE_FIND_LIBRARY_SUFFIXES})