summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-26 15:01:03 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-26 15:01:03 +0000
commite500be0abeae09ead4648ddc2fae30dc8234c229 (patch)
tree53879561334c9a887a8ebc72950ab8a47a6b5d0b /dev-util/bnfc/bnfc-2.1.2.ebuild
parentVersion bump to 20041022. Ebuild and man pages provided by paul.greidanus@ual... (diff)
downloadgentoo-2-e500be0abeae09ead4648ddc2fae30dc8234c229.tar.gz
gentoo-2-e500be0abeae09ead4648ddc2fae30dc8234c229.tar.bz2
gentoo-2-e500be0abeae09ead4648ddc2fae30dc8234c229.zip
Initial import (#54750)
Diffstat (limited to 'dev-util/bnfc/bnfc-2.1.2.ebuild')
-rw-r--r--dev-util/bnfc/bnfc-2.1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/bnfc/bnfc-2.1.2.ebuild b/dev-util/bnfc/bnfc-2.1.2.ebuild
new file mode 100644
index 000000000000..b146cc606055
--- /dev/null
+++ b/dev-util/bnfc/bnfc-2.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bnfc/bnfc-2.1.2.ebuild,v 1.1 2004/10/26 15:01:03 kosmikus Exp $
+
+DESCRIPTION="BNF Converter -- a sophisticated parser generator"
+HOMEPAGE="http://www.cs.chalmers.se/~markus/BNFC/"
+SRC_URI="http://www.cs.chalmers.se/~markus/BNFC/${PN}_${PV}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="doc"
+
+DEPEND=">=virtual/ghc-6.2
+ doc? ( virtual/tetex )"
+
+RDEPEND="virtual/libc"
+
+S="${WORKDIR}/BNFC"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ emake GHC_OPTS=-O || die "emake failed"
+}
+
+src_install() {
+ dobin bnfc
+ if [ `use doc` ] ; then
+ cd doc
+ pdflatex LBNF-report.tex
+ pdflatex LBNF-report.tex
+ dodoc LBNF-report.pdf
+ fi
+}