summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-11-16 06:38:37 +0000
committerZack Welch <zwelch@gentoo.org>2002-11-16 06:38:37 +0000
commit891da0b2cc088daccb16af9fb67c734e0495ff9a (patch)
treef4ffea2966f05d3b9468fa4f8b24269ce0f5e973 /dev-util/bitkeeper
parentadd BitKeeper License (diff)
downloadgentoo-2-891da0b2cc088daccb16af9fb67c734e0495ff9a.tar.gz
gentoo-2-891da0b2cc088daccb16af9fb67c734e0495ff9a.tar.bz2
gentoo-2-891da0b2cc088daccb16af9fb67c734e0495ff9a.zip
add bitkeeper 3.0 ebuild
Diffstat (limited to 'dev-util/bitkeeper')
-rw-r--r--dev-util/bitkeeper/ChangeLog12
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0.ebuild61
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/bitkeeper/ChangeLog b/dev-util/bitkeeper/ChangeLog
new file mode 100644
index 000000000000..2075dd8a8c4e
--- /dev/null
+++ b/dev-util/bitkeeper/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.1 2002/11/16 06:38:37 zwelch Exp $
+
+*bitkeeper-3.0 (15 Nov 2002)
+
+ 15 Nov 2002; Zach Welch <zwelch@gentoo.org> :
+ Add to cvs
+
+ 10 Nov 2002; Evan Powers <powers.161@osu.edu> :
+ User submitted ebuild, bug 7922
+
diff --git a/dev-util/bitkeeper/bitkeeper-3.0.ebuild b/dev-util/bitkeeper/bitkeeper-3.0.ebuild
new file mode 100644
index 000000000000..e6562405ce28
--- /dev/null
+++ b/dev-util/bitkeeper/bitkeeper-3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.ebuild,v 1.1 2002/11/16 06:38:37 zwelch Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="BitKeeper is a scalable configuration management system."
+SRC_URI=""
+HOMEPAGE="http://www.bitkeeper.com"
+DEPEND=">=virtual/glibc-2.2
+ >=dev-lang/tcl-8.3.3
+ X? ( >=dev-lang/tk-8.3.3 )"
+
+SLOT="0"
+LICENSE="BKL"
+KEYWORDS="x86 ppc sparc alpha"
+
+# I'm not sure what the official way to do this is...
+use 'x86' >/dev/null && A="bk-3.0-x86-glibc22-linux.bin"
+use 'ppc' >/dev/null && A="bk-3.0-powerpc-glibc21-linux.bin"
+use 'sparc' >/dev/null && A="bk-3.0-sparc-glibc21-linux.bin"
+use 'alpha' >/dev/null && A="bk-3.0-alpha-glibc21-linux.bin"
+
+pkg_setup() {
+ if [ ! -f ${DISTDIR}/${A} ] ; then
+ einfo "****************************************************************************"
+ einfo "* Perform the following steps to install this package:"
+ einfo "* - Sign up at ${HOMEPAGE}"
+ einfo "* - Check your mail and visit the download location"
+ einfo "* - Download ${A} and place it in ${DISTDIR}"
+ einfo "* - emerge this package again"
+ einfo "****************************************************************************"
+ die "Follow the above instructions, please"
+ fi
+}
+
+src_unpack() {
+ mkdir ${S}
+ cp ${DISTDIR}/${A} ${S}/${A}
+ chmod 755 ${S}/${A}
+ echo 'none' | ${S}/${A} > ${S}/output 2>/dev/null
+ installer=`sed -n -e "s/Installation script: \(.*\)/\1/p" ${S}/output`
+ archive=`sed -n -e "s/Gzipped tar archive: \(.*\)/\1/p" ${S}/output`
+ mv $installer ${S}/installer
+ mv $archive ${S}/archive
+}
+
+src_install () {
+ mkdir -p ${D}/opt ${D}/etc/env.d
+ cd ${D}/opt && tar -xzf ${S}/archive
+ mv ${D}/opt/bitkeeper ${D}/opt/${P}
+ cat <<EOF >${D}/etc/env.d/10bitkeeper
+# Generated by ${P}.ebuild
+PATH=/opt/${P}
+ROOTPATH=/opt/${P}
+MANPATH=/opt/${P}/man
+EOF
+}
+
+pkg_postinst () {
+ einfo "Run 'bk regressions' to verify the installation. (Recommended)"
+}