summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 21:35:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 21:35:28 +0000
commitabd4bfe157e8ce589ba7b981ec2425eea7162585 (patch)
tree30e70c5c6bb3d56f3eefb1f314c0ffc39101ef1a /dev-util/astyle
parentfixing Manifest (diff)
downloadgentoo-2-abd4bfe157e8ce589ba7b981ec2425eea7162585.tar.gz
gentoo-2-abd4bfe157e8ce589ba7b981ec2425eea7162585.tar.bz2
gentoo-2-abd4bfe157e8ce589ba7b981ec2425eea7162585.zip
add inherit eutils
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/astyle-1.15.3-r1.ebuild23
-rw-r--r--dev-util/astyle/astyle-1.15.3.ebuild23
2 files changed, 24 insertions, 22 deletions
diff --git a/dev-util/astyle/astyle-1.15.3-r1.ebuild b/dev-util/astyle/astyle-1.15.3-r1.ebuild
index f9f61e3fb81d..7af0631bcc2a 100644
--- a/dev-util/astyle/astyle-1.15.3-r1.ebuild
+++ b/dev-util/astyle/astyle-1.15.3-r1.ebuild
@@ -1,20 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3-r1.ebuild,v 1.2 2004/03/28 21:30:49 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3-r1.ebuild,v 1.3 2004/04/25 21:31:01 vapier Exp $
-ZIP="astyle_${PV}.zip"
-S=${WORKDIR}
-DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java
-source code."
-SRC_URI="mirror://sourceforge/astyle/${ZIP}"
-HOMEPAGE="http://astyle.sourceforge.net"
+inherit eutils
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}.zip"
-SLOT="0"
LICENSE="Artistic | GPL-2"
-KEYWORDS="x86 sparc ~ppc"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc"
+IUSE=""
DEPEND=">=app-arch/unzip-5.42"
+S=${WORKDIR}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/cmd-line-fix.diff
@@ -24,8 +26,7 @@ src_compile() {
emake || die
}
-src_install () {
- into /usr
+src_install() {
dobin astyle
dohtml astyle.html astyle_release_notes.html license.html
dodoc INSTALL.TXT
diff --git a/dev-util/astyle/astyle-1.15.3.ebuild b/dev-util/astyle/astyle-1.15.3.ebuild
index 15d651ecc98c..88fba5e81d0b 100644
--- a/dev-util/astyle/astyle-1.15.3.ebuild
+++ b/dev-util/astyle/astyle-1.15.3.ebuild
@@ -1,20 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3.ebuild,v 1.10 2004/03/28 18:04:06 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3.ebuild,v 1.11 2004/04/25 21:31:47 vapier Exp $
-ZIP="astyle_${PV}.zip"
-S=${WORKDIR}
-DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java
-source code."
-SRC_URI="mirror://sourceforge/astyle/${ZIP}"
-HOMEPAGE="http://astyle.sourceforge.net"
+inherit eutils
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}.zip"
-SLOT="0"
LICENSE="Artistic | GPL-2"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE=""
DEPEND=">=app-arch/unzip-5.42"
+S=${WORKDIR}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/cmd-line-fix.diff
@@ -24,8 +26,7 @@ src_compile() {
emake || die
}
-src_install () {
- into /usr
+src_install() {
dobin astyle
dohtml astyle.html astyle_release_notes.html license.html
dodoc INSTALL.TXT