summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-21 16:12:31 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-21 16:12:31 +0000
commit016de14ddefae34e3494ff1eb09fc948cb385d12 (patch)
treeb63fc7f0cff1237c9d399665d02e1fded3f0a771 /dev-util/aap/aap-1.072.ebuild
parentStable on ppc64 (Manifest recommit) (diff)
downloadgentoo-2-016de14ddefae34e3494ff1eb09fc948cb385d12.tar.gz
gentoo-2-016de14ddefae34e3494ff1eb09fc948cb385d12.tar.bz2
gentoo-2-016de14ddefae34e3494ff1eb09fc948cb385d12.zip
Bump, bug #75148
Diffstat (limited to 'dev-util/aap/aap-1.072.ebuild')
-rw-r--r--dev-util/aap/aap-1.072.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/aap/aap-1.072.ebuild b/dev-util/aap/aap-1.072.ebuild
new file mode 100644
index 000000000000..d9be749098b3
--- /dev/null
+++ b/dev-util/aap/aap-1.072.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aap/aap-1.072.ebuild,v 1.1 2004/12/21 16:12:31 ciaranm Exp $
+
+IUSE="doc"
+
+DESCRIPTION="Bram Moolenaar's super-make program"
+HOMEPAGE="http://www.a-a-p.org/"
+SRC_URI="mirror://sourceforge/a-a-p/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~ia64 ~x86 ~amd64 ~sparc ~mips"
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/python-1.5"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir ${S} && cd ${S} && unzip -q ${DISTDIR}/${A} || die
+}
+
+src_install() {
+ rm doc/*.sgml
+ rm doc/*.pdf
+
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ cp -R doc/* ${D}/usr/share/doc/${PF}/html
+ fi
+ rm doc/*.html
+ rm -fr doc/images
+
+ dodoc doc/*
+ doman aap.1
+ rm -rf doc aap.1
+
+ # Move the remainder directly into the dest tree
+ dodir /usr/share
+ cd ${WORKDIR}
+ mv aap ${D}/usr/share
+
+ # Create a symbolic link for the executable
+ dodir /usr/bin
+ ln -s ../share/aap/aap ${D}/usr/bin/aap
+}