summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-05-08 16:26:08 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-05-08 16:26:08 +0000
commitacb69a0d4e3b0e0a8717f7178676c5e7ff39deff (patch)
tree6905a3a582a0ccd02c5f244110b33d1ae5bb7abc /dev-tex
parentDropping the old patch. (diff)
downloadgentoo-2-acb69a0d4e3b0e0a8717f7178676c5e7ff39deff.tar.gz
gentoo-2-acb69a0d4e3b0e0a8717f7178676c5e7ff39deff.tar.bz2
gentoo-2-acb69a0d4e3b0e0a8717f7178676c5e7ff39deff.zip
Initial version.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/abntex/ChangeLog10
-rw-r--r--dev-tex/abntex/abntex-0.9_beta2.ebuild60
-rw-r--r--dev-tex/abntex/metadata.xml12
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-tex/abntex/ChangeLog b/dev-tex/abntex/ChangeLog
new file mode 100644
index 000000000000..e2a2ab881584
--- /dev/null
+++ b/dev-tex/abntex/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-tex/abntex
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/abntex/ChangeLog,v 1.1 2011/05/08 16:26:08 rafaelmartins Exp $
+
+*abntex-0.9_beta2 (08 May 2011)
+
+ 08 May 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +abntex-0.9_beta2.ebuild, +metadata.xml:
+ Initial version.
+
diff --git a/dev-tex/abntex/abntex-0.9_beta2.ebuild b/dev-tex/abntex/abntex-0.9_beta2.ebuild
new file mode 100644
index 000000000000..2ac2511ec738
--- /dev/null
+++ b/dev-tex/abntex/abntex-0.9_beta2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/abntex/abntex-0.9_beta2.ebuild,v 1.1 2011/05/08 16:26:08 rafaelmartins Exp $
+
+EAPI=3
+
+inherit latex-package
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="LaTeX macros for writing documents following the ABNT norms."
+HOMEPAGE="http://abntex.codigolivre.org.br/ http://abntex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-doc-${MY_PV}.tar.gz )"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples lyx"
+
+DEPEND="dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended
+ lyx? ( app-office/lyx )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P%-*}"
+
+src_prepare() {
+ # fix permissions
+ find . -type f -exec chmod 0644 "{}" + || die 'chmod 0644 failed.'
+ find . -type d -exec chmod 0755 "{}" + || die 'chmod 0755 failed.'
+}
+
+src_install() {
+ dobin bin/geratss || die 'dobin failed.'
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r texmf/doc/* || die 'could not install examples.'
+ fi
+
+ rm -rf texmf/doc
+
+ insinto /usr/share/texmf-site
+ doins -r texmf/* || die 'could not install texmf.'
+
+ if use lyx; then
+ insinto /usr/share/lyx
+ doins -r lyx/* || die 'could not install lyx files.'
+ fi
+
+ dodoc LEIAME || die 'could not install LEIAME'
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/docs
+ doins -r compiled.docs/* || die "could not install doc"
+ fi
+}
diff --git a/dev-tex/abntex/metadata.xml b/dev-tex/abntex/metadata.xml
new file mode 100644
index 000000000000..b769d8f3f826
--- /dev/null
+++ b/dev-tex/abntex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <use>
+ <flag name='lyx'>Install with <pkg>app-office/lyx</pkg> layout</flag>
+ </use>
+</pkgmetadata>