summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-03 04:15:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-03 04:15:18 +0000
commit2e74b4b02ed88883c9deb3944c06565fe101543c (patch)
tree080877a36234c4e334711da28fdc3c006ffcd7f4 /dev-tex/envlab
parentno need to depend on virtual/tetex, latex-package eclass does it for us (diff)
downloadgentoo-2-2e74b4b02ed88883c9deb3944c06565fe101543c.tar.gz
gentoo-2-2e74b4b02ed88883c9deb3944c06565fe101543c.tar.bz2
gentoo-2-2e74b4b02ed88883c9deb3944c06565fe101543c.zip
rev bump to install into texmf-site
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'dev-tex/envlab')
-rw-r--r--dev-tex/envlab/ChangeLog7
-rw-r--r--dev-tex/envlab/envlab-1.2-r1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-tex/envlab/ChangeLog b/dev-tex/envlab/ChangeLog
index 63fd5921ad5e..da9f253b871d 100644
--- a/dev-tex/envlab/ChangeLog
+++ b/dev-tex/envlab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/envlab
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/ChangeLog,v 1.12 2008/09/03 04:10:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/ChangeLog,v 1.13 2008/09/03 04:15:18 aballier Exp $
+
+*envlab-1.2-r1 (03 Sep 2008)
+
+ 03 Sep 2008; Alexis Ballier <aballier@gentoo.org> +envlab-1.2-r1.ebuild:
+ rev bump to install into texmf-site
03 Sep 2008; Alexis Ballier <aballier@gentoo.org> envlab-1.2.ebuild:
no need to depend on virtual/tetex, latex-package eclass does it for us
diff --git a/dev-tex/envlab/envlab-1.2-r1.ebuild b/dev-tex/envlab/envlab-1.2-r1.ebuild
new file mode 100644
index 000000000000..7fff762a40ee
--- /dev/null
+++ b/dev-tex/envlab/envlab-1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/envlab-1.2-r1.ebuild,v 1.1 2008/09/03 04:15:18 aballier Exp $
+
+inherit latex-package
+
+S="${WORKDIR}/${PN}"
+LICENSE="LPPL-1.2"
+DESCRIPTION="A LaTeX module to format envelopes"
+HOMEPAGE="http://planck.psu.edu/~boris/"
+# downloaded from
+# ftp://ftp.ctan.org/pub/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+SLOT="0"
+DEPEND=""
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ ebegin "Compiling ${PN}"
+ latex envlab.ins || die
+ pdflatex elguide.tex || die
+ pdflatex elguide.tex || die
+ pdflatex envlab.drv || die
+ pdflatex envlab.drv || die
+ eend
+}
+
+src_install() {
+ latex-package_src_install
+
+ insinto ${TEXMF}/tex/latex/${PN}
+ doins *.cfg
+
+ dodoc readme.v12
+}