summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2003-06-09 07:32:39 +0000
committerMatthew Turk <satai@gentoo.org>2003-06-09 07:32:39 +0000
commit94e21ef86dd483b6a35e471c2d40a82edfcec4d2 (patch)
tree8a31a20f6fef67b04575306c2239d876da3d9866 /dev-tex/cpp2latex
parentRemoving all the old latex packages, preparing for dev-tex. (diff)
downloadgentoo-2-94e21ef86dd483b6a35e471c2d40a82edfcec4d2.tar.gz
gentoo-2-94e21ef86dd483b6a35e471c2d40a82edfcec4d2.tar.bz2
gentoo-2-94e21ef86dd483b6a35e471c2d40a82edfcec4d2.zip
Fixing up some oddities.
Diffstat (limited to 'dev-tex/cpp2latex')
-rw-r--r--dev-tex/cpp2latex/ChangeLog16
-rw-r--r--dev-tex/cpp2latex/Manifest4
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.2.ebuild30
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-tex/cpp2latex/ChangeLog b/dev-tex/cpp2latex/ChangeLog
new file mode 100644
index 000000000000..b54f6e124e43
--- /dev/null
+++ b/dev-tex/cpp2latex/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for app-text/cpp2latex
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/ChangeLog,v 1.1 2003/06/09 07:32:39 satai Exp $
+
+*cpp2latex-2.2 (31 Dec 2002)
+
+ 31 Dec 2002; Richard Garand <richard@garandnet.net>
+
+ Version bump; added patch to fix gcc 3 errors and add option
+ to prevent linewrapping.
+
+*cpp2latex-2.1 (03 Oct 2002)
+
+ 03 Oct 2002; Richard Garand <richard@garandnet.net>
+
+ First ebuild.
diff --git a/dev-tex/cpp2latex/Manifest b/dev-tex/cpp2latex/Manifest
new file mode 100644
index 000000000000..740f9b2d29ed
--- /dev/null
+++ b/dev-tex/cpp2latex/Manifest
@@ -0,0 +1,4 @@
+MD5 0af205cfaad4f5824a83b0d35c19e93f ChangeLog 495
+MD5 d288704f7ede0342d7a7496324e360c1 cpp2latex-2.2.ebuild 696
+MD5 8d070a7f0ef6e8e397177d4e6d1f5694 files/digest-cpp2latex-2.2 65
+MD5 10328506b7ce2bd8214880117f387093 files/main.cpp.patch 9876
diff --git a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
new file mode 100644
index 000000000000..c1c0dc450a5f
--- /dev/null
+++ b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.1 2003/06/09 07:32:39 satai Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A program to convert C++ code to LaTeX source"
+SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
+HOMEPAGE="http://www.arnoldarts.de/cpp2latex.html"
+
+DEPEND="virtual/glibc
+ app-text/tetex"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ patch -p 0 < ${FILESDIR}/main.cpp.patch
+}
+
+src_compile () {
+ econf
+ emake
+}
+
+src_install () {
+ make install DESTDIR=${D} || die make install failed
+}