summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-26 04:02:53 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-26 04:02:53 +0000
commitc7ebb85f56d4f2b83313af0c72489cad26c4243d (patch)
tree15c2714a4893c2a203a15c152e63ad17bebd04be /dev-tcltk
parentthanks Az :) (diff)
downloadgentoo-2-c7ebb85f56d4f2b83313af0c72489cad26c4243d.tar.gz
gentoo-2-c7ebb85f56d4f2b83313af0c72489cad26c4243d.tar.bz2
gentoo-2-c7ebb85f56d4f2b83313af0c72489cad26c4243d.zip
added optional installation of examples (if 'doc' is defined)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog6
-rw-r--r--dev-tcltk/expect/expect-5.37.1-r2.ebuild65
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.37.1-r21
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index ad4c3f58b976..81f5aab833b7 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-tcltk/expect
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.4 2002/09/23 17:13:38 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.5 2002/10/26 04:02:49 george Exp $
*expect-5.37.1 (08 July 2002)
+ 25 Oct 2002; George Shapovalov <george@gentoo.org> epect-5.37.1-r2.ebuild :
+ modified src_install to add examples if doc is defined.
+ Revision bumped for testing.
+
23 Sep 2002; Olivier Reisch <doctomoe@gentoo.org> expect-5.37.1-r1.ebuild:
Added ppc keyword
diff --git a/dev-tcltk/expect/expect-5.37.1-r2.ebuild b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
new file mode 100644
index 000000000000..f1a400498f7b
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r2.ebuild,v 1.1 2002/10/26 04:02:49 george Exp $
+
+IUSE="X doc"
+
+#remove the trailing ".0" from the tarball version
+S=${WORKDIR}/${P%.1}
+
+DESCRIPTION="Expect is a tool for automating interactive applications"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+HOMEPAGE="http://expect.nist.gov/"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="BSD"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+
+src_compile() {
+
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+ #docs
+ dodoc Changelog FAQ HISTORY NEWS README
+
+ #install examples if 'doc' is set
+ if use doc; then
+ dodir /usr/share/doc/${PF}/examples/
+ cp example/* /usr/share/doc/${PF}/examples/
+ fi
+}
+
diff --git a/dev-tcltk/expect/files/digest-expect-5.37.1-r2 b/dev-tcltk/expect/files/digest-expect-5.37.1-r2
new file mode 100644
index 000000000000..6543a4578374
--- /dev/null
+++ b/dev-tcltk/expect/files/digest-expect-5.37.1-r2
@@ -0,0 +1 @@
+MD5 d570837b6dc6311036d7bdeab19f0e03 expect-5.37.1.tar.gz 517284