summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-05-13 22:21:45 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-05-13 22:21:45 +0000
commite20a49c0aa396c45a91aca2692a14cbf1fe32bf6 (patch)
tree7a2c54a2decb15271c78051ae89745572e5014ef /dev-tcltk/tclcl
parentstable on hppa (diff)
downloadgentoo-2-e20a49c0aa396c45a91aca2692a14cbf1fe32bf6.tar.gz
gentoo-2-e20a49c0aa396c45a91aca2692a14cbf1fe32bf6.tar.bz2
gentoo-2-e20a49c0aa396c45a91aca2692a14cbf1fe32bf6.zip
Fixed http.tcl library location.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-tcltk/tclcl')
-rw-r--r--dev-tcltk/tclcl/ChangeLog6
-rw-r--r--dev-tcltk/tclcl/files/tclcl-1.16-http.patch22
-rw-r--r--dev-tcltk/tclcl/tclcl-1.16.ebuild8
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-tcltk/tclcl/ChangeLog b/dev-tcltk/tclcl/ChangeLog
index 7c6440ea37dd..0cc41cdd45c3 100644
--- a/dev-tcltk/tclcl/ChangeLog
+++ b/dev-tcltk/tclcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/tclcl
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/ChangeLog,v 1.8 2005/04/03 13:56:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/ChangeLog,v 1.9 2005/05/13 22:21:45 matsuu Exp $
+
+ 13 May 2005; MATSUU Takuto <matsuu@gentoo.org>
+ +files/tclcl-1.16-http.patch, tclcl-1.16.ebuild:
+ Fixed http.tcl library location.
*tclcl-1.16 (03 Apr 2005)
diff --git a/dev-tcltk/tclcl/files/tclcl-1.16-http.patch b/dev-tcltk/tclcl/files/tclcl-1.16-http.patch
new file mode 100644
index 000000000000..2e7c79b3b47f
--- /dev/null
+++ b/dev-tcltk/tclcl/files/tclcl-1.16-http.patch
@@ -0,0 +1,22 @@
+diff -Naur tclcl-1.16.orig/conf/configure.in.tcl tclcl-1.16/conf/configure.in.tcl
+--- tclcl-1.16.orig/conf/configure.in.tcl 2005-01-04 06:33:01.000000000 +0900
++++ tclcl-1.16/conf/configure.in.tcl 2005-05-14 07:02:53.000000000 +0900
+@@ -178,6 +178,7 @@
+ tcl_http_places=" \
+ $V_LIBRARY_TCL \
+ $V_LIBRARY_TCL/http \
++ $V_LIBRARY_TCL/http2.5 \
+ $V_LIBRARY_TCL/http2.4 \
+ $V_LIBRARY_TCL/http2.3 \
+ $V_LIBRARY_TCL/http2.1 \
+diff -Naur tclcl-1.16.orig/configure tclcl-1.16/configure
+--- tclcl-1.16.orig/configure 2005-01-20 05:58:48.000000000 +0900
++++ tclcl-1.16/configure 2005-05-14 07:03:06.000000000 +0900
+@@ -5531,6 +5531,7 @@
+ tcl_http_places=" \
+ $V_LIBRARY_TCL \
+ $V_LIBRARY_TCL/http \
++ $V_LIBRARY_TCL/http2.5 \
+ $V_LIBRARY_TCL/http2.4 \
+ $V_LIBRARY_TCL/http2.3 \
+ $V_LIBRARY_TCL/http2.1 \
diff --git a/dev-tcltk/tclcl/tclcl-1.16.ebuild b/dev-tcltk/tclcl/tclcl-1.16.ebuild
index 430592f0fdd3..4a304fe47a6d 100644
--- a/dev-tcltk/tclcl/tclcl-1.16.ebuild
+++ b/dev-tcltk/tclcl/tclcl-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.16.ebuild,v 1.1 2005/04/03 13:56:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclcl/tclcl-1.16.ebuild,v 1.2 2005/05/13 22:21:45 matsuu Exp $
inherit eutils
@@ -18,6 +18,12 @@ DEPEND=">=dev-lang/tcl-8.3.2
>=dev-lang/tk-8.3.2
>=dev-tcltk/otcl-1.0.8"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-http.patch
+}
+
src_compile() {
local tclv tkv myconf