summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-02-20 11:52:27 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-02-20 11:52:27 +0000
commitcad9844f83e89fa68001ef194b949e608c62e3e8 (patch)
tree77f577c211c10a6395637f4ed1132f69ba25cd1b /dev-scheme
parentold (diff)
downloadgentoo-2-cad9844f83e89fa68001ef194b949e608c62e3e8.tar.gz
gentoo-2-cad9844f83e89fa68001ef194b949e608c62e3e8.tar.bz2
gentoo-2-cad9844f83e89fa68001ef194b949e608c62e3e8.zip
bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile/ChangeLog38
-rw-r--r--dev-scheme/guile/guile-1.8.4.ebuild82
2 files changed, 119 insertions, 1 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index db5620b81db6..d290524d6b0e 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,42 @@
# ChangeLog for dev-scheme/guile
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.44 2008/02/19 19:53:14 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.45 2008/02/20 11:52:27 hkbst Exp $
+
+*guile-1.8.4 (20 Feb 2008)
+
+ 20 Feb 2008; Marijn Schouten <hkBst@gentoo.org> +guile-1.8.4.ebuild:
+ bump:
+ - Bugs fixed
+
+ - CR (ASCII 0x0d) is (again) recognized as a token delimiter by the
+ reader
+ - Fixed a segmentation fault which occurred when displaying the
+ backtrace of a stack with a promise object (made by `delay') in it
+ - Make `accept' leave guile mode while blocking
+ - `scm_c_read ()' and `scm_c_write ()' now type-check their port
+ argument
+ - Fixed a build problem on AIX (use of func_data identifier)
+ - Fixed a segmentation fault which occurred when hashx-ref or
+ hashx-set! was called with an associator proc that returns neither
+ a pair nor #f.
+ - Secondary threads now always return a valid module for
+ (current-module).
+ - Avoid MacOS build problems caused by incorrect combination of "64"
+ system and library calls.
+ - `guile-snarf' now honors `$TMPDIR'
+ - `guile-config compile' now reports CPPFLAGS used at compile-time
+ - Fixed build with Sun Studio (Solaris 9)
+ - Fixed wrong-type-arg errors when creating zero length SRFI-4
+ uniform vectors on AIX.
+ - Fixed a deadlock that occurs upon GC with multiple threads.
+ - Fixed compile problem with GCC on Solaris and AIX (use of _Complex_I)
+ - Fixed autotool-derived build problems on AIX 6.1.
+ - Fixed NetBSD/alpha support
+ - Fixed MacOS build problem caused by use of rl_get_keymap(_name)
+
+ - New modules (see the manual for details)
+
+ - `(srfi srfi-69)'
19 Feb 2008; Christoph Mende <angelos@gentoo.org> guile-1.8.3-r2.ebuild:
Stable on amd64, bug #210465
diff --git a/dev-scheme/guile/guile-1.8.4.ebuild b/dev-scheme/guile/guile-1.8.4.ebuild
new file mode 100644
index 000000000000..601d2265fb12
--- /dev/null
+++ b/dev-scheme/guile/guile-1.8.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.4.ebuild,v 1.1 2008/02/20 11:52:27 hkbst Exp $
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Scheme interpreter"
+HOMEPAGE="http://www.gnu.org/software/guile/"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RESTRICT="!regex? ( test )"
+
+DEPEND=">=dev-libs/gmp-4.1 >=sys-devel/libtool-1.5.6 sys-devel/gettext"
+
+# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
+# but there are lots of collisions. Most in /usr/share/libguile. Therefore
+# I'm slotting this in the same slot as guile-1.6* for now.
+SLOT="12"
+MAJOR="1.8"
+
+IUSE="networking regex discouraged deprecated elisp nls debug-freelist debug-malloc debug threads"
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+
+ sed "s_sleep 999_sleep 1_" -i test-suite/tests/popen.test
+}
+
+src_compile() {
+ # see bug #178499
+ filter-flags -ftree-vectorize
+
+#will fail for me if posix is disabled or without modules -- hkBst
+ econf \
+ --disable-error-on-warning \
+ --disable-static \
+ --enable-posix \
+ $(use_enable networking) \
+ $(use_enable regex) \
+ $(use deprecated || use_enable discouraged) \
+ $(use_enable deprecated) \
+ $(use_enable elisp) \
+ $(use_enable nls) \
+ --disable-rpath \
+ $(use_enable debug-freelist) \
+ $(use_enable debug-malloc) \
+ $(use_enable debug guile-debug) \
+ $(use_with threads) \
+ --with-modules
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+
+ # texmacs needs this, closing bug #23493
+ dodir /etc/env.d
+ echo "GUILE_LOAD_PATH=\"/usr/share/guile/${MAJOR}\"" > "${D}"/etc/env.d/50guile
+
+ # necessary for registering slib, see bug 206896
+ keepdir /usr/share/guile/site
+}
+
+pkg_postinst() {
+ [ "${ROOT}" == "/" ] && pkg_config
+}
+
+pkg_config() {
+ if has_version dev-scheme/slib; then
+ einfo "Registering slib with guile"
+ install_slib_for_guile
+ fi
+}
+
+pkg_prerm() {
+ rm -f "${ROOT}"/usr/share/guile/site/slibcat
+}