summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-11-18 18:29:34 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-11-18 18:29:34 +0000
commit176237e2e14932094aaee515ea83f4b176be134a (patch)
treebfe4cd8c2ddc668f623074940f607fce400219d7 /dev-scheme
parentStable on ppc64; bug #199332 (diff)
downloadgentoo-2-176237e2e14932094aaee515ea83f4b176be134a.tar.gz
gentoo-2-176237e2e14932094aaee515ea83f4b176be134a.tar.bz2
gentoo-2-176237e2e14932094aaee515ea83f4b176be134a.zip
bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/files/digest-gambit-4.1.03
-rw-r--r--dev-scheme/gambit/gambit-4.1.0.ebuild126
3 files changed, 135 insertions, 1 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index cfa293a2febf..d357d4b0bc1b 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.13 2007/09/12 12:06:53 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.14 2007/11/18 18:29:34 hkbst Exp $
+
+*gambit-4.1.0 (18 Nov 2007)
+
+ 18 Nov 2007; Marijn Schouten <hkBst@gentoo.org> +gambit-4.1.0.ebuild:
+ bump
*gambit-4.0.1 (12 Sep 2007)
diff --git a/dev-scheme/gambit/files/digest-gambit-4.1.0 b/dev-scheme/gambit/files/digest-gambit-4.1.0
new file mode 100644
index 000000000000..3c39cf9c3f3d
--- /dev/null
+++ b/dev-scheme/gambit/files/digest-gambit-4.1.0
@@ -0,0 +1,3 @@
+MD5 4cc60b62a8065826e486d3c8f94aa903 gambc-v4_1_0.tgz 11764506
+RMD160 162095343bd5163b1f1c5c30862f3831bc396a50 gambc-v4_1_0.tgz 11764506
+SHA256 4addf724778f5170b0a2bafe86fb433ce52a4ec32e0d7acc35959e3f38800f27 gambc-v4_1_0.tgz 11764506
diff --git a/dev-scheme/gambit/gambit-4.1.0.ebuild b/dev-scheme/gambit/gambit-4.1.0.ebuild
new file mode 100644
index 000000000000..390641ca4b79
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.1.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.0.ebuild,v 1.1 2007/11/18 18:29:34 hkbst Exp $
+
+inherit eutils elisp-common check-reqs autotools multilib
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P}
+
+IUSE="big-iron emacs static"
+
+pkg_setup() {
+ if ! use big-iron; then
+ ewarn "NOT compiling each Scheme module as a single C function"
+ ewarn "NOT using gcc specific optimizations"
+# ewarn "NOT compiling syntax-case macro system"
+ ewarn "approximately 0.5GB ram will be needed"
+ ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="768" check_reqs
+ else
+ ewarn "compiling each Scheme module as a single C function"
+ ewarn "using gcc specific optimizations"
+# ewarn "compiling syntax-case macro system"
+ ewarn "approximately 2GB ram will be needed instead of 0.5GB"
+ ewarn "this will cause heavy thrashing of your system"
+ ewarn "and may cause your compiler to crash when it runs out of memory"
+ ewarn "unless your system is BIG IRON"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="2560" check_reqs
+ fi
+}
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+# cp configure.ac configure.ac.old
+ sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
+ -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
+ #don't force -O1
+ sed 's:$DASH_O1::' -i configure.ac
+ eautoreconf
+# diff -u configure.ac.old configure.ac
+}
+
+src_compile() {
+# econf $(if use static; then echo --disable-shared; else echo --enable-shared; fi) \
+ econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
+
+ emake || die "emake failed"
+
+ if use emacs; then
+ ( cd misc; elisp-comp *.el )
+ fi
+
+ # compile syntax-case
+# if use big-iron; then
+# einfo "compiling syntax-case.scm..."
+# LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
+# fi
+}
+
+_src_test() {
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if ! GAMBCOPT="=." emake -j1 check; then
+ hasq test $FEATURES && die "Make test failed. See above for details."
+ hasq test $FEATURES || eerror "Make test failed. See above for details."
+ fi
+}
+
+src_install() {
+ einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
+
+ rm ${D}/usr/current
+
+# use big-iron && dolib syntax-case.*
+ mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
+
+ # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
+ mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
+
+ # remove emacs/site-lisp/gambit.el
+ rm -r ${D}/usr/share/emacs
+ if use emacs; then
+ elisp-install ${PN} misc/*.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+
+ dodoc INSTALL.txt README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # create some more explicit names
+ dosym gsc-gambit usr/bin/gambit-compiler
+ dosym gsi usr/bin/gambit-interpreter
+
+# dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
+ echo "GAMBCOPT=\"=/usr/\"" > "${T}/50gambit" && doenvd "${T}/50gambit"
+
+# ewarn "syntax-case will be automatically loaded for R5RS+ goodness"
+# ewarn "edit /etc/gambcext if you want to set your own options"
+# dosym /etc/gambcext /usr/gambcext
+# echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/etc/gambcext
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}