summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-19 08:04:13 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-19 08:04:13 +0000
commitf901bc144075369b412747d71182353cc1a618ac (patch)
tree8f5f8e2f6160c22eb093c2f514266cc3849e074c /dev-ruby
parentVersion bump for security bug 501750. (diff)
downloadgentoo-2-f901bc144075369b412747d71182353cc1a618ac.tar.gz
gentoo-2-f901bc144075369b412747d71182353cc1a618ac.tar.bz2
gentoo-2-f901bc144075369b412747d71182353cc1a618ac.zip
Version bump for security bug 501750.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.3.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 40ebe753bcaa..f627a8660011 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.68 2014/02/19 07:18:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.69 2014/02/19 08:04:13 graaff Exp $
+
+*activemodel-4.0.3 (19 Feb 2014)
+
+ 19 Feb 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-4.0.3.ebuild:
+ Version bump for security bug 501750.
*activemodel-3.2.17 (19 Feb 2014)
diff --git a/dev-ruby/activemodel/activemodel-4.0.3.ebuild b/dev-ruby/activemodel/activemodel-4.0.3.ebuild
new file mode 100644
index 000000000000..eea75d4d5f6b
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-4.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.3.ebuild,v 1.1 2014/02/19 08:04:13 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.0.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}