summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-13 04:03:21 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-13 04:03:21 +0000
commitf4b6e7497ee797c0933535597b9fe55798faa7eb (patch)
treeb9f2b7f86ef18a47878b4e06e8048339e2d6fade /dev-ruby
parentAdd fix for postgres' server include path by Alexander Sulfrian. Fixes bug #4... (diff)
downloadgentoo-2-f4b6e7497ee797c0933535597b9fe55798faa7eb.tar.gz
gentoo-2-f4b6e7497ee797c0933535597b9fe55798faa7eb.tar.bz2
gentoo-2-f4b6e7497ee797c0933535597b9fe55798faa7eb.zip
Version bump.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rb-gsl/ChangeLog9
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-1.15.3.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-ruby/rb-gsl/ChangeLog b/dev-ruby/rb-gsl/ChangeLog
index d77233da940c..f3be08fe5128 100644
--- a/dev-ruby/rb-gsl/ChangeLog
+++ b/dev-ruby/rb-gsl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rb-gsl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v 1.2 2013/11/30 19:50:50 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/ChangeLog,v 1.3 2014/01/13 04:03:21 mrueg Exp $
+
+*rb-gsl-1.15.3.1 (13 Jan 2014)
+
+ 13 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +rb-gsl-1.15.3.1.ebuild:
+ Version bump.
*rb-gsl-1.15.3-r1 (30 Nov 2013)
diff --git a/dev-ruby/rb-gsl/rb-gsl-1.15.3.1.ebuild b/dev-ruby/rb-gsl/rb-gsl-1.15.3.1.ebuild
new file mode 100644
index 000000000000..c36f1e89453a
--- /dev/null
+++ b/dev-ruby/rb-gsl/rb-gsl-1.15.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-gsl/rb-gsl-1.15.3.1.ebuild,v 1.1 2014/01/13 04:03:21 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby interface to GNU Scientific Library"
+HOMEPAGE="http://rb-gsl.rubyforge.org/ https://github.com/david-macmahon/rb-gsl"
+#SRC_URI="https://github.com/david-macmahon/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND+=" sci-libs/gsl"
+RDEPEND+=" sci-libs/gsl"
+
+RUBY_S="${PN}-${P}"
+
+each_ruby_prepare() {
+ sed -e \
+ "/ruby -w -I/ s:#\truby -w *:${RUBY} -w -I ../../lib -I ../../ext -I . :" \
+ -e "/ruby -w \`basename/ s/^/# /" -i tests/run-test.sh || die
+ sed -i '/$CPPFLAGS =/a \$LDFLAGS = " -L#{narray_config} -l:narray.so "+$LDFLAGS' ext/extconf.rb || die
+ sed -i -e 's/qactual/actual/' tests/linalg/TDN.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+each_ruby_test() {
+ cd tests || die
+ ./run-test.sh || die
+}