summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-06-26 20:07:02 +0000
committerHans de Graaff <graaff@gentoo.org>2014-06-26 20:07:02 +0000
commitee0024467d3b1cd70090c0c4da781b0d5330fa3e (patch)
tree9c71bd7109e09c11b86d80ff7bfd103ec6a35470 /dev-ruby
parentVersion bump to Rails 4.1.2. (diff)
downloadgentoo-2-ee0024467d3b1cd70090c0c4da781b0d5330fa3e.tar.gz
gentoo-2-ee0024467d3b1cd70090c0c4da781b0d5330fa3e.tar.bz2
gentoo-2-ee0024467d3b1cd70090c0c4da781b0d5330fa3e.zip
Version bump to Rails 4.1.2.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.1.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 99a9f384f00e..707c453ab18a 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.262 2014/06/26 19:21:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.263 2014/06/26 20:07:02 graaff Exp $
+
+*actionmailer-4.1.2 (26 Jun 2014)
+
+ 26 Jun 2014; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.1.2.ebuild:
+ Version bump to Rails 4.1.2.
*actionmailer-4.0.6 (26 Jun 2014)
diff --git a/dev-ruby/actionmailer/actionmailer-4.1.2.ebuild b/dev-ruby/actionmailer/actionmailer-4.1.2.ebuild
new file mode 100644
index 000000000000..dfa7b83da9eb
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.1.2.ebuild,v 1.1 2014/06/26 20:07:02 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}