summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-08 09:53:38 +0000
committerTom William Payne <twp@gentoo.org>2003-04-08 09:53:38 +0000
commitdec1233bcc29d36cd6e43c58368c020d6455bf4a (patch)
treeb61f48501f4e9cad101428143aa0f4727463453a /dev-ruby
parentUpdated to 0.6.7 with ebuild fixes (diff)
downloadgentoo-2-dec1233bcc29d36cd6e43c58368c020d6455bf4a.tar.gz
gentoo-2-dec1233bcc29d36cd6e43c58368c020d6455bf4a.tar.bz2
gentoo-2-dec1233bcc29d36cd6e43c58368c020d6455bf4a.zip
Initial commit.
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mysql-ruby/ChangeLog8
-rw-r--r--dev-ruby/mysql-ruby/mysql-ruby-2.4.4a.ebuild21
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/mysql-ruby/ChangeLog b/dev-ruby/mysql-ruby/ChangeLog
new file mode 100644
index 000000000000..d7da35eed49d
--- /dev/null
+++ b/dev-ruby/mysql-ruby/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-ruby/mysql-ruby
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/ChangeLog,v 1.1 2003/04/08 09:53:38 twp Exp $
+
+*mysql-ruby-2.4.4a (07 Apr 2003)
+
+ 07 Apr 2003; Tom Payne <twp@gentoo.org> :
+ Initial import.
diff --git a/dev-ruby/mysql-ruby/mysql-ruby-2.4.4a.ebuild b/dev-ruby/mysql-ruby/mysql-ruby-2.4.4a.ebuild
new file mode 100644
index 000000000000..d398d91ec974
--- /dev/null
+++ b/dev-ruby/mysql-ruby/mysql-ruby-2.4.4a.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/mysql-ruby-2.4.4a.ebuild,v 1.1 2003/04/08 09:53:38 twp Exp $
+
+DESCRIPTION="A Ruby extention library to use MySQL"
+HOMEPAGE="http://www.tmtm.org/en/mysql/ruby/"
+SRC_URI="http://www.tmtm.org/en/mysql/ruby/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+DEPEND=">=dev-lang/ruby-1.6.8
+ >=dev-db/mysql-3.23.54"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}