summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-07-22 07:08:10 +0000
committerHans de Graaff <graaff@gentoo.org>2009-07-22 07:08:10 +0000
commitc5576d1d151ce37200ab0196867dd976da273ce0 (patch)
tree01eb9b910e63aba2076c9deb8cddca2712af98d5 /dev-ruby
parentSend second argument (close) to libnotify for compability with 0.4.5. (diff)
downloadgentoo-2-c5576d1d151ce37200ab0196867dd976da273ce0.tar.gz
gentoo-2-c5576d1d151ce37200ab0196867dd976da273ce0.tar.bz2
gentoo-2-c5576d1d151ce37200ab0196867dd976da273ce0.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.3.ebuild22
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index f81cd7a46480..40fd237dd7d4 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.104 2009/05/28 16:09:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.105 2009/07/22 07:08:10 graaff Exp $
+
+*activerecord-2.3.3 (22 Jul 2009)
+
+ 22 Jul 2009; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.3.ebuild:
+ Version bump for Rails 2.3.3. Some association enhancements.
28 May 2009; Raúl Porcel <armin76@gentoo.org> activerecord-2.3.2.ebuild:
ia64 stable wrt #270331
diff --git a/dev-ruby/activerecord/activerecord-2.3.3.ebuild b/dev-ruby/activerecord/activerecord-2.3.3.ebuild
new file mode 100644
index 000000000000..b11f7952f7e4
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.3.ebuild,v 1.1 2009/07/22 07:08:10 graaff Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-2.3.3"
+RDEPEND="${DEPEND}
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"