summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-19 04:35:26 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-19 04:35:26 +0000
commitbd67e307774e0b14209e3e0819c64680932ce23e (patch)
tree548461ff406d7734507947d624a981ec72296860 /dev-ruby
parentBump for #420479 (diff)
downloadgentoo-2-bd67e307774e0b14209e3e0819c64680932ce23e.tar.gz
gentoo-2-bd67e307774e0b14209e3e0819c64680932ce23e.tar.bz2
gentoo-2-bd67e307774e0b14209e3e0819c64680932ce23e.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fastercsv/ChangeLog9
-rw-r--r--dev-ruby/fastercsv/fastercsv-1.5.5.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-ruby/fastercsv/ChangeLog b/dev-ruby/fastercsv/ChangeLog
index 92d197b23554..aec97ea9c6fb 100644
--- a/dev-ruby/fastercsv/ChangeLog
+++ b/dev-ruby/fastercsv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fastercsv
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/ChangeLog,v 1.13 2011/01/14 07:37:52 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/ChangeLog,v 1.14 2012/06/19 04:35:26 graaff Exp $
+
+*fastercsv-1.5.5 (19 Jun 2012)
+
+ 19 Jun 2012; Hans de Graaff <graaff@gentoo.org> +fastercsv-1.5.5.ebuild:
+ Version bump.
*fastercsv-1.5.4 (14 Jan 2011)
diff --git a/dev-ruby/fastercsv/fastercsv-1.5.5.ebuild b/dev-ruby/fastercsv/fastercsv-1.5.5.ebuild
new file mode 100644
index 000000000000..b941e6a407c3
--- /dev/null
+++ b/dev-ruby/fastercsv/fastercsv-1.5.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fastercsv/fastercsv-1.5.5.ebuild,v 1.1 2012/06/19 04:35:26 graaff Exp $
+
+EAPI=2
+
+# ruby19 → not needed, it's bundled as part of the main package and with recent version this package will raise an exception.
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc/html"
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGELOG README TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FasterCSV is a replacement for the standard CSV library"
+HOMEPAGE="http://fastercsv.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}