summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-26 06:13:11 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-26 06:13:11 +0000
commit9015b14e411f01cdc62cd87db57ed9522d6c9232 (patch)
tree79168ce825c89ee831b89740c66f9ca1e6870b5d /dev-ruby
parentUpdated 2.0.9999 and added 2.1.9999 by backporting fixes from 9999; adapted 2... (diff)
downloadgentoo-2-9015b14e411f01cdc62cd87db57ed9522d6c9232.tar.gz
gentoo-2-9015b14e411f01cdc62cd87db57ed9522d6c9232.tar.bz2
gentoo-2-9015b14e411f01cdc62cd87db57ed9522d6c9232.zip
Restrict tests since all of them require network connectivity.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/shorturl/ChangeLog5
-rw-r--r--dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-ruby/shorturl/ChangeLog b/dev-ruby/shorturl/ChangeLog
index 9ba2f5c7016f..be384497bd4c 100644
--- a/dev-ruby/shorturl/ChangeLog
+++ b/dev-ruby/shorturl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/shorturl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/ChangeLog,v 1.23 2013/10/04 18:30:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/ChangeLog,v 1.24 2013/10/26 06:13:11 graaff Exp $
+
+ 26 Oct 2013; Hans de Graaff <graaff@gentoo.org> shorturl-1.0.0-r1.ebuild:
+ Restrict tests since all of them require network connectivity.
*shorturl-1.0.0-r1 (04 Oct 2013)
diff --git a/dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild b/dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild
index 7c56da180241..e05013cb7ee0 100644
--- a/dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild
+++ b/dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild,v 1.1 2013/10/04 18:30:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shorturl/shorturl-1.0.0-r1.ebuild,v 1.2 2013/10/26 06:13:11 graaff Exp $
EAPI=5
@@ -21,6 +21,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-macos"
IUSE=""
+# All tests require network connectivity.
+RESTRICT="test"
+
each_ruby_test() {
${RUBY} -Ilib:test test/ts_all.rb || die "tests failed"
}