summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-03 06:20:06 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-03 06:20:06 +0000
commit6ea303792239157736a583fa3d3a97bf836e40c8 (patch)
tree5a23a504a25b0d433fe333ec6679aa431f956a01 /dev-ruby
parentVersion bump to Rails 4.1.4 for security bug 516084. (diff)
downloadgentoo-2-6ea303792239157736a583fa3d3a97bf836e40c8.tar.gz
gentoo-2-6ea303792239157736a583fa3d3a97bf836e40c8.tar.bz2
gentoo-2-6ea303792239157736a583fa3d3a97bf836e40c8.zip
Version bump to Rails 4.1.4 for security bug 516084.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-4.1.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 78c67e0c705a..31e7677b108a 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.283 2014/07/03 05:57:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.284 2014/07/03 06:20:06 graaff Exp $
+
+*actionpack-4.1.4 (03 Jul 2014)
+
+ 03 Jul 2014; Hans de Graaff <graaff@gentoo.org> +actionpack-4.1.4.ebuild:
+ Version bump to Rails 4.1.4 for security bug 516084.
*actionpack-4.0.8 (03 Jul 2014)
diff --git a/dev-ruby/actionpack/actionpack-4.1.4.ebuild b/dev-ruby/actionpack/actionpack-4.1.4.ebuild
new file mode 100644
index 000000000000..6dee565b1e86
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-4.1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.1.4.ebuild,v 1.1 2014/07/03 06:20:06 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ >=dev-ruby/rack-1.5.2:1.5
+ >=dev-ruby/rack-test-0.6.2:0.6"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
+}