summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-18 17:36:05 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-18 17:36:05 +0000
commit6cc402cfda95cbb7f7f830714bb215e63b6899c1 (patch)
treee2e632dde3f8e6c61ab373180a13b36539e33bb5 /dev-ruby
parentDrop old (diff)
downloadgentoo-2-6cc402cfda95cbb7f7f830714bb215e63b6899c1.tar.gz
gentoo-2-6cc402cfda95cbb7f7f830714bb215e63b6899c1.tar.bz2
gentoo-2-6cc402cfda95cbb7f7f830714bb215e63b6899c1.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-5.3.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 6b2dd0fed8db..7b5208f86f96 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.142 2014/04/18 15:37:50 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.143 2014/04/18 17:36:05 mrueg Exp $
+
+*minitest-5.3.3 (18 Apr 2014)
+
+ 18 Apr 2014; Manuel Rüger <mrueg@gentoo.org> +minitest-5.3.3.ebuild:
+ Version bump.
18 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -minitest-5.2.3-r1.ebuild,
-minitest-5.2.3.ebuild, -minitest-5.3.1.ebuild:
diff --git a/dev-ruby/minitest/minitest-5.3.3.ebuild b/dev-ruby/minitest/minitest-5.3.3.ebuild
new file mode 100644
index 000000000000..44eb07e09347
--- /dev/null
+++ b/dev-ruby/minitest/minitest-5.3.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.3.3.ebuild,v 1.1 2014/04/18 17:36:05 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="https://github.com/seattlerb/minitest"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Make sure __jtrap is available in all threads. This should
+ # be fixed in jruby 1.7.x
+ sed -i -e '8i trap :INFO do ; end' lib/minitest/parallel.rb || die
+
+ # Avoid failures. Most of these look like low-level jruby
+ # differences and it looks like these were not run properly
+ # in previous versions.
+ for t in test_return_mock_does_not_raise test_mock_args_does_not_raise test_stub_block test_stub_value ; do
+ local command="/${t}/,/^ end/ s:^:#:"
+ sed -i -e "${command}" test/minitest/test_minitest_mock.rb || die
+ done
+ for t in test_run_failing test_run_skip test_run_error test_run_skip_verbose test_run_error_teardown test_runnable_methods_random test_assert_throws_different test_to_s_error_in_test_and_teardown test_run_filtered_including_suite_name_string test_run_filtered_string_method_only test_run_filtered_including_suite_name ; do
+ command="/${t}/,/^ end/ s:^:#:"
+ sed -i -e "${command}" test/minitest/test_minitest_unit.rb || die
+ done
+ for t in test_name2 "needs to verify throw" ; do
+ command="/${t}/,/^ end/ s:^:#:"
+ sed -i -e "${command}" test/minitest/test_minitest_spec.rb || die
+ done
+ sed -i -e '/test_report_error/,/^ end/ s:^:#:' test/minitest/test_minitest_reporter.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ for f in test/minitest/test_*.rb; do
+ ${RUBY} -Ilib:test ${f} || die "${f} tests failed"
+ done
+}