summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-27 19:24:46 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-27 19:24:46 +0000
commit4bcbf6edd70201e86645b6f2b3b8abca2ec9d25d (patch)
tree9bea9d3e0224fe5202a83f717b11cdbb33a480bd /dev-ruby
parentDrop unneeded test-unit dependency, add ruby22. (diff)
downloadgentoo-2-4bcbf6edd70201e86645b6f2b3b8abca2ec9d25d.tar.gz
gentoo-2-4bcbf6edd70201e86645b6f2b3b8abca2ec9d25d.tar.bz2
gentoo-2-4bcbf6edd70201e86645b6f2b3b8abca2ec9d25d.zip
Fix the testrb-2 wrapper to work with test-unit 3.x as well.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/test-unit/ChangeLog8
-rw-r--r--dev-ruby/test-unit/files/testrb-36
-rw-r--r--dev-ruby/test-unit/test-unit-3.0.9-r1.ebuild59
3 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 6eff6e8dcd55..1e111ee6ae19 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.107 2015/01/26 08:35:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.108 2015/01/27 19:24:46 graaff Exp $
+
+*test-unit-3.0.9-r1 (27 Jan 2015)
+
+ 27 Jan 2015; Hans de Graaff <graaff@gentoo.org> +test-unit-3.0.9-r1.ebuild,
+ +files/testrb-3:
+ Fix the testrb-2 wrapper to work with test-unit 3.x as well.
26 Jan 2015; Jeroen Roovers <jer@gentoo.org> test-unit-3.0.9.ebuild:
Marked ~hppa (bug #537838).
diff --git a/dev-ruby/test-unit/files/testrb-3 b/dev-ruby/test-unit/files/testrb-3
new file mode 100644
index 000000000000..4f5a8467f46d
--- /dev/null
+++ b/dev-ruby/test-unit/files/testrb-3
@@ -0,0 +1,6 @@
+#!/usr/bin/env ruby
+gem 'test-unit', '>= 2.5', '<4'
+require 'test/unit'
+(r = Test::Unit::AutoRunner.new(true)).process_args(ARGV) or
+ abort r.options.banner + " tests..."
+exit r.run
diff --git a/dev-ruby/test-unit/test-unit-3.0.9-r1.ebuild b/dev-ruby/test-unit/test-unit-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..e70327a74536
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.0.9-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-3.0.9-r1.ebuild,v 1.1 2015/01/27 19:24:46 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.md doc/text/news.md"
+
+inherit ruby-fakegem
+
+# Assume for now that ruby22 is not eselected yet and only depend on
+# yard for the other ruby implementations. Without this assumption
+# bootstrapping ruby22 won't be possible due to the yard dependency
+# tree.
+USE_RUBY="${USE_RUBY/ruby22/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+
+LICENSE="|| ( Ruby GPL-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa"
+IUSE="doc test"
+
+# power_assert does not work with ruby19 but is not needed for backward
+# compatibility:
+# https://github.com/k-tsj/power_assert/issues/8#issuecomment-71363455
+USE_RUBY="${USE_RUBY/ruby19/}" ruby_add_rdepend "dev-ruby/power_assert"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Remove metadata to avoid registering the unsupported
+ # power_assert dependency.
+ rm ../metadata || die
+ ;;
+ esac
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}